Bug 1024121 - Incorrect/Wrong Battery Percentage and Information is reported
Incorrect/Wrong Battery Percentage and Information is reported
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: upower (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 18:35 EDT by bull500
Modified: 2015-02-17 12:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 12:50:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
contains the log of upower and acpi (10.50 KB, text/x-vhdl)
2013-10-28 18:35 EDT, bull500
no flags Details

  None (edit)
Description bull500 2013-10-28 18:35:26 EDT
Created attachment 816934 [details]
contains the log of upower and acpi

Description of problem:
The battery dischrage percentage shown is incorrect. 
Also the estimated battery capacity shows 44000hrs(wrong -> 3.5hrs max).

Version-Release number of selected component (if applicable):
upower-0.9.20-1.fc19.x86_64
kernel-3.11.4-201.fc19.x86_64

How reproducible:
Its reproducible every time I switch on the laptop.

Steps to Reproduce:
1. Ensure the laptop is fully charged, plugged in and then turn on laptop.
2. Login wait till the system loads completely.
3. Disconnect charger and the Batter Remaining time shows 1.3 hrs along with wrong % Remaining

Actual results:
My battery life last for about 3 - 3.5Hrs
I've tried this on Windows 7(dual boot). I get correct battery reading and percentage
No problems with battery.

Expected results:
Battery should last for 3-3.5Hrs and show the correct discharge percentage

Additional info:
upower shows the correct discharge rate if I do "systemctl stop upower.service" or kill the upowerd service
also correct info gets shown by restart of "systemctl restart upower.service"

I have attached the details reported by upower and acpi
Comment 1 bull500 2013-11-03 05:19:23 EST
Incase you people need additional data please do let me know :). 
I just want this problem solved :/
Its kind of frustrating to restart this upower.service everytime i boot my system.
Comment 2 Alex Markley 2013-11-08 11:38:18 EST
All,

I am also affected by this bug. It is very annoying! Frequently the system incorrectly calculates the remaining battery percentage as less than 10% remaining, which causes it to unexpectedly suspend/hibernate/shut down!

This is absolutely awful behavior, especially for new users.

The bug has been reported and fixed in upstream upower. See: https://bugs.freedesktop.org/show_bug.cgi?id=60214#c7

Can we please have this fix backported to Fedora 19?

Thanks,
Comment 3 bull500 2013-11-13 06:38:30 EST
Another problem also
upowerd fails to start on boot - on every alternate boot. Really Weird.
I restart again and its fine
Comment 4 bull500 2014-02-08 06:49:00 EST
This issue is still present on Fedora 20 as well.
i have to do a "systemctl restart upower.service" to correct the battery indicator on the top gnome shell bar, after i disconnect my charger
Comment 5 Fedora End Of Life 2015-01-09 15:23:45 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2015-02-17 12:50:54 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.