Bug 1024131 - Evolution sometimes flushes entire cache of IMAP+ subfolder, resulting in zero messages
Evolution sometimes flushes entire cache of IMAP+ subfolder, resulting in zer...
Status: CLOSED DUPLICATE of bug 1022750
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 19:31 EDT by Bojan Smojver
Modified: 2013-11-05 06:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 06:32:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 704513 None None None Never

  None (edit)
Description Bojan Smojver 2013-10-28 19:31:37 EDT
Description of problem:
This happens almost every time on suspend resume. All the folder on IMAP server (dovecot running on F-19) vanish. It also causes defaults to fail to local folders - really annoying.

Version-Release number of selected component (if applicable):
evolution-3.8.5-2.fc19.x86_64

How reproducible:
Almost always.

Steps to Reproduce:
1. Suspend (IMAP+ account configured).
2. Resume.
3. Folders vanish. Restart of Evo required.

Actual results:
Folders disappear.

Expected results:
Did not happen until recently.

Additional info:
https://bugzilla.gnome.org/show_bug.cgi?id=704513
Comment 1 Bojan Smojver 2013-10-28 19:32:21 EDT
That Gnome bug says fixed. That's not true for 3.8.5.
Comment 2 Kevin R. Page 2013-10-30 10:09:30 EDT
I have also been seeing this in recent F19 evolution (looking at yum.log, possibly since evolution-data-server-3.8.5-5.fc19.x86_64). Always on suspend and resume, possibly at other times.

In the same time frame I've been experiencing other regressions which, in combination, are nigh on making evolution unusable. I'm currently seeing ~20 "Unknown background operation" tickers, and have also been seeing lots of downloading messages for offline and updating/refreshing folders lists. They frequently don't clear for tens of minutes until I have to kill evo. These do not just occur after suspend/resume, but periodically (and anecdotally more reliably shortly after suspend/resume).

Looking at the upstream bug it seems like these could also be issues around re-indexing and caching? Does this seem likely, or should I file a separate bug?
Comment 3 Kevin R. Page 2013-10-31 10:18:06 EDT
All the above problems (including vanishing folder in the original report and my secondary issues in comment #2) so far appear to be resolved by reverting, via yum downgrade, to:

evolution-data-server-3.8.3-1.fc19.x86_64
evolution-ews-3.8.3-1.fc19.x86_64
Comment 4 Milan Crha 2013-11-05 06:32:45 EST
Thanks for a bug report. What seemed to fix an issue for one person doesn't seem to fix it for others, thus I'll revert the patch from 3.8.5-5 for now. Upstream bug mentions that 3.10.0-1 has this fixed properly (it's part of Fedora 20), thus let's keep the fix for it, rather than chase all the changes between 3.8.5 and 3.10.0 and pick only those relevant.

I mark this as a duplicate of an older bug, just to cover more people.

*** This bug has been marked as a duplicate of bug 1022750 ***

Note You need to log in before you can comment on or make changes to this bug.