Bug 1024145 - RHQ agent NullPointerException (NPE) in communication thread
RHQ agent NullPointerException (NPE) in communication thread
Status: CLOSED DUPLICATE of bug 1052390
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
4.5
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 20:31 EDT by Elias Ross
Modified: 2014-02-18 22:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-18 22:24:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elias Ross 2013-10-28 20:31:51 EDT
Description of problem:

For some reason I've been seeing this on a few hosts.

2013-10-29 00:25:00,254 ERROR [ClientCommandSenderTask Timer Thread #12990] (JBossRemotingRemoteCommunicator)- {JBossRemotingRemoteCommunicator.init-callback-failed}The initializ
e callback has failed. It will be tried again. Cause: java.lang.NullPointerException:null. Cause: java.lang.NullPointerException
2013-10-29 00:25:00,254 WARN  [InventoryManager.availability-1] (InventoryManager)- Could not transmit availability report to server
java.lang.NullPointerException
        at org.jboss.remoting.Client.invoke(Client.java:2084)
        at org.jboss.remoting.Client.invoke(Client.java:879)
        at org.rhq.enterprise.communications.command.client.JBossRemotingRemoteCommunicator.rawSend(JBossRemotingRemoteCommunicator.java:514)
        at org.rhq.enterprise.communications.command.client.JBossRemotingRemoteCommunicator.sendWithoutCallbacks(JBossRemotingRemoteCommunicator.java:456)
        at org.rhq.enterprise.communications.command.client.JBossRemotingRemoteCommunicator.sendWithoutInitializeCallback(JBossRemotingRemoteCommunicator.java:475)
        at org.rhq.enterprise.agent.AgentMain.sendConnectRequestToServer(AgentMain.java:2112)
        at org.rhq.enterprise.agent.ConnectAgentInitializeCallback.sendingInitialCommand(ConnectAgentInitializeCallback.java:43)
        at org.rhq.enterprise.communications.command.client.JBossRemotingRemoteCommunicator.invokeInitializeCallbackIfNeeded(JBossRemotingRemoteCommunicator.java:579)
        at org.rhq.enterprise.communications.command.client.JBossRemotingRemoteCommunicator.send(JBossRemotingRemoteCommunicator.java:491)
        at org.rhq.enterprise.communications.command.client.AbstractCommandClient.invoke(AbstractCommandClient.java:143)
        at org.rhq.enterprise.communications.command.client.ClientCommandSender.send(ClientCommandSender.java:1084)
        at org.rhq.enterprise.communications.command.client.ClientCommandSenderTask.send(ClientCommandSenderTask.java:229)
        at org.rhq.enterprise.communications.command.client.ClientCommandSenderTask.call(ClientCommandSenderTask.java:107)
        at org.rhq.enterprise.communications.command.client.ClientCommandSenderTask.call(ClientCommandSenderTask.java:55)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:662)
2013-10-29 00:25:08,584 ERROR [RHQ Server Polling Thread] (JBossRemotingRemoteCommunicator)- {JBossRemotingRemoteCommunicator.init-callback-failed}The initialize callback has failed. It will be tried again. Cause: java.lang.NullPointerException:null. Cause: java.lang.NullPointerException

The agent appears down. It may have been caused by a botched failover or multiple failovers.

org.jboss.remoting.Client.invoker is null somehow.


Version-Release number of selected component (if applicable): 4.9, though with some custom patches for the agent, though not really related to the communications systems.


How reproducible: Unclear. Maybe failover sensitive?


Additional info: Multiple servers, one was decommissioned.
Comment 1 Elias Ross 2014-02-18 22:24:38 EST
Duplicate of

*** This bug has been marked as a duplicate of bug 1052390 ***

Note You need to log in before you can comment on or make changes to this bug.