Bug 102417 - perl 5.8.1-90 rc4 fails to build XML::LibXML due to invalid my_perl macro
perl 5.8.1-90 rc4 fails to build XML::LibXML due to invalid my_perl macro
Status: CLOSED UPSTREAM
Product: Red Hat Raw Hide
Classification: Retired
Component: perl (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-14 18:16 EDT by Kaj J. Niemi
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-06 14:08:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2003-08-14 18:16:21 EDT
Description of problem:
build complans about my_perl being undeclared in perl-libxml-sax.c.

Version-Release number of selected component (if applicable):
perl-5.8.1-90.rc4.0

How reproducible:
Always

Steps to Reproduce:
1. Have libxml2, libxml2-devel around
2. Have XML::SAX, XML::NamespaceSupport, XML::LibXML::Common around
3. Get XML::LibXML (1.53 or later) from
<http://search.cpan.org/author/PHISH/XML-LibXML-1.54/>
4. Unbz2 & untar
5. perl Makefile.PL && make
    
Actual results:
during build
gcc -c  -I/usr/include/libxml2 -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS
-DDEBUGGING -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -g -pipe -march=i386 -mcpu=i686 
 -DVERSION=\"1.54\" -DXS_VERSION=\"1.54\" -fPIC
"-I/usr/lib/perl5/5.8.1/i386-linux-thread-multi/CORE"  -DHAVE_UTF8 -DHAVE_BLANK
perl-libxml-sax.c
perl-libxml-sax.c: In function `PmmSAXInitialize':
perl-libxml-sax.c:82: error: `my_perl' undeclared (first use in this function)
perl-libxml-sax.c:82: error: (Each undeclared identifier is reported only once
perl-libxml-sax.c:82: error: for each function it appears in.)
make: *** [perl-libxml-sax.o] Error 1


Expected results:
Should build cleanly

Additional info:
This used to work upto pre 5.8.1 snapshots (those that were still named 5.8.0)

IMHO looks like a perl environment problem since nothing inside the build tree
actually refers to my_perl ...

[~/rpm/BUILD/XML-LibXML-1.54]% egrep my_perl **/*
[1 ~/rpm/BUILD/XML-LibXML-1.54]%
Comment 1 Kaj J. Niemi 2003-08-23 11:26:11 EDT
Still a problem with perl-5.8.1-90.rc4.2.
Comment 2 Kaj J. Niemi 2003-09-06 14:08:18 EDT
XML::LibXML 1.58 fixes build problem with perl 5.8.1.

Note You need to log in before you can comment on or make changes to this bug.