Bug 1024173 - sendmail should be included explicitly for Fedora 20
sendmail should be included explicitly for Fedora 20
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: general (Show other bugs)
develop
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 00:44 EDT by Amit Saha
Modified: 2015-07-26 18:15 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 00:12:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Saha 2013-10-29 00:44:05 EDT
Description of problem:

Fedora 20 removed sendmail from @core, hence we will have to include it in the Fedora kickstarts (conditional if Fedora 20 is provisioned).

Traceback in reserversys task:

Redirecting to /bin/systemctl start  sendmail.service
Failed to issue method call: Unit sendmail.service failed to load: No such file or directory. See system logs and 'systemctl status sendmail.service' for details.
./runtest.sh: line 175: sendmail: command not found


Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Nick Coghlan 2013-10-29 02:15:15 EDT
Isn't this just a missing dependency in the reservesys task definition?
Comment 2 Amit Saha 2013-10-29 03:00:31 EDT
(In reply to Nick Coghlan from comment #1)
> Isn't this just a missing dependency in the reservesys task definition?

Good question that. So I think the question to ask here, is it going to be only required for the proper functionality of the reservesys task? If so, yes the reservesys's tasks's dependency list should have sendmail in it.
Comment 3 Amit Saha 2013-11-11 00:12:47 EST
'sendmail' is already listed as a dependency for reservesys. Turns out 'sendmail' was missing from the mirror I was provisioning Fedora from.

Note You need to log in before you can comment on or make changes to this bug.