Bug 1024176 - Can launch firstboot even when the parameter RUN_FIRSTBOOT=NO in /etc/sysconfig/firstboot file
Can launch firstboot even when the parameter RUN_FIRSTBOOT=NO in /etc/syscon...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firstboot (Show other bugs)
6.5
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Martin Kolman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 00:56 EDT by Shwetha Kallesh
Modified: 2016-05-10 20:59 EDT (History)
4 users (show)

See Also:
Fixed In Version: firstboot-1.110.15-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 20:59:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2013-10-29 00:56:38 EDT
Description of problem:
Can launch firstboot even when the parameter RUN_FIRSTBOOT=NO in  /etc/sysconfig/firstboot file

Version-Release number of selected component (if applicable):
[root@rhel65 ~]# rpm -qa | grep firstboot
firstboot-1.110.15-1.el6.x86_64
subscription-manager-firstboot-1.10.2-1.git.38.20a82f5.el6.x86_64



How reproducible:


Steps to Reproduce:
1.[root@rhel65 ~]# cat /etc/sysconfig/firstboot
RUN_FIRSTBOOT=YES


2.[root@rhel65 ~]# firstboot -r 
firstboot DEBUG: Loading consumer info from identity certificates.
firstboot DEBUG: Loading current RPM profile.
firstboot INFO: Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
firstboot INFO: Connection Built: host: 10.70.35.34, port: 8443, handler: /candlepin
firstboot DEBUG: ContectConnection
firstboot INFO: Checking current system info against cache: /var/lib/rhsm/cache/installed_products.json



3.  [root@rhel65 ~]# cat /etc/sysconfig/firstboot
RUN_FIRSTBOOT=NO


4.  [root@rhel65 ~]# firstboot -r
firstboot DEBUG: Loading consumer info from identity certificates.
firstboot DEBUG: Loading current RPM profile.
firstboot INFO: Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
firstboot INFO: Connection Built: host: 10.70.35.34, port: 8443, handler: /candlepin
firstboot DEBUG: ContectConnection
firstboot INFO: Checking current system info against cache: /var/lib/rhsm/cache/installed_products.json
firstboot INFO: No changes.
firstboot DEBUG: Installed product IDs: ['100000000000060', '1000000000000023', '100000000000011', '27060', '1', '37069', '37068', '37080', '37065', '37067', '37060', '37062', '100000000000006', '100000000000005', '100000000000002', '100000000000003', '100000000000000', '100000000000001', '213412341236', '213412341237', '213412341234', '213412341235', '100000000000020', '32060', '88888', '100000000000069', '900', '917571', '801', '806', '37070']
firstboot DEBUG: Loading CA PEM certificates from: /etc/rhsm/ca/

Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2013-11-01 01:47:12 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Samantha N. Bueno 2015-10-22 11:03:23 EDT
Moving this to 6.8 and setting dev_ack+; this is a simple fix that we can pull in.
Comment 7 errata-xmlrpc 2016-05-10 20:59:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0944.html

Note You need to log in before you can comment on or make changes to this bug.