This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1024180 - qcow should not be in the virt-image 5 manual.
qcow should not be in the virt-image 5 manual.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Giuseppe Scrivano
Virtualization Bugs
:
Depends On:
Blocks: 1024189
  Show dependency treegraph
 
Reported: 2013-10-29 01:18 EDT by hyao@redhat.com
Modified: 2016-04-26 11:29 EDT (History)
9 users (show)

See Also:
Fixed In Version: python-virtinst-0.600.0-20.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1024189 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:23:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hyao@redhat.com 2013-10-29 01:18:27 EDT
Description
qcow is in the virt-image 5 manual and qed is missed.
Version:
# rpm -qa libvirt python-virtinst qemu-kvm
python-virtinst-0.600.0-18.el6.noarch
qemu-kvm-0.12.1.2-2.414.el6.x86_64
libvirt-0.10.2-29.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a virtual image XML descriptor file with qcow disk included.
# cat image.xml
<image>
<name>demo</name>
<domain>
<boot type="hvm">
<guest>
<arch>x86_64</arch>
</guest>
<os>
<loader dev="hd"/>
</os>
<drive disk="mydisk" target="hda"/>
<drive disk="user" target="hdb"/>
</boot>
<devices>
<vcpu>1</vcpu>
<memory>262144</memory>
interface/>
<graphics/>
</devices>
</domain>
<storage>
<disk id="mydisk" file="kvm-rhel6.5-x86_64-raw.img" use="system" format="raw"/>
<disk id="user" file="/var/lib/libvirt/images/user.img" use="user" format="qcow" size="1000"/>
</storage>
</image>


2. Create a virtual machine from image.xml
#virt-image  image.xml

Creating guest demo...
Allocating 'user.img'                                                                                   | 1.0 GB     00:00    
ERROR    internal error Process exited while reading console log output: char device redirected to /dev/pts/4
qemu-kvm: -drive file=/var/lib/libvirt/images/user.img,if=none,id=drive-ide0-0-1,format=qcow,cache=none: 'qcow' invalid format

Domain installation does not appear to have been successful.
If it was, you can restart your domain by running:
  virsh --connect qemu:///system start demo
otherwise, please restart your installation.

3. Check the format description in manual.
#man 5 virt-image
...
  the format attribute giving the format of the disk file. Currently, this can be one of: "raw" "iso","qcow", "qcow2", or "vmdk".

Actual results:
qcow is not supported by qemu-kvm and qcow is in the virt-image manual. 


Expected results:
According to the qemu-kvm notification, qcow format should be deteleted from virt-image 5 manual.

Additional info:
Comment 5 zhoujunqin 2014-05-06 02:54:06 EDT
Reproduce with python-virtinst-0.600.0-18.el6.noarch.

Verified with package:
python-virtinst-0.600.0-20.el6.noarch
virt-manager-0.9.0-20.el6.x86_64

steps:
1. Prepare a virtual image XML descriptor file with qcow disk included as Comment 0.

2. Create a virtual machine from image.xml
# virt-image image.xml 

Creating guest demo...
ERROR    internal error process exited while connecting to monitor: char device redirected to /dev/pts/1
qemu-kvm: -drive file=/var/lib/libvirt/images/user.img,if=none,id=drive-ide0-0-1,format=qcow,cache=none: 'qcow' invalid format

Domain installation does not appear to have been successful.
If it was, you can restart your domain by running:
  virsh --connect qemu:///system start demo
otherwise, please restart your installation.

3. Check the format description in manual.
# man 5 virt-image
STORAGE
...
       ยท   the format attribute giving the format of the disk file. Currently, this can be one of: "raw", "iso",
           "qcow2", or "vmdk".
...

Since qcow format has been deteleted from virt-image 5 manual, so marked as verified.
Comment 6 errata-xmlrpc 2014-10-14 02:23:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1444.html

Note You need to log in before you can comment on or make changes to this bug.