Bug 1024208 - login screen doesn't list my account any more
login screen doesn't list my account any more
Status: CLOSED DUPLICATE of bug 1029195
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 02:56 EDT by Gerd Hoffmann
Modified: 2013-12-11 17:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-11 17:20:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerd Hoffmann 2013-10-29 02:56:11 EDT
Description of problem:
Updated to latest RHEL-7 compose today.
Now my name doesn't appear on the login screen any more.

Version-Release number of selected component (if applicable):
RHEL-7.0-20131024.0

How reproducible:
100%

Additional info:
I can still login by picking 'not listed', then typing my userid.
I can't change the session type though, the menu for that isn't there.
Comment 2 Ray Strode [halfline] 2013-10-30 16:20:32 EDT
are you still seeing this?

Do you see if you boot with enforcing=0 on the kernel command line?

Would you mind editing /etc/gdm/custom.conf and putting Enable=true in the [debug] section, rebooting, and then attaching the output of journalctl -b -a --full ?

Are you using sssd or any sort of remote login infrastructure?
Comment 3 Gerd Hoffmann 2013-11-05 01:51:09 EST
(In reply to Ray Strode [halfline] from comment #2)
> are you still seeing this?

Just updated to 20131030.1 snapshot.  Still happens.

> Do you see if you boot with enforcing=0 on the kernel command line?

enforcing=0 doesn't change anything.

> Would you mind editing /etc/gdm/custom.conf and putting Enable=true in the
> [debug] section, rebooting, and then attaching the output of journalctl -b
> -a --full ?

Done, will attach in a moment.

> Are you using sssd or any sort of remote login infrastructure?

Not for login.  Kerberos is configured, but I just kinit after logging in.
Comment 5 Gerd Hoffmann 2013-12-11 06:04:56 EST
Found easy reproducer: install latest rhel7 compose (20131127.1), using kickstart, create a user using this kickstart line:

user --name=kraxel --gecos="Gerd Hoffmann" --uid=500 --password=${secret}

On first boot rhel7 asks me to create a user.  On the login screen that one shows up, the kickstart-created doesn't.  Login via "not listed" link works.
Comment 6 Ray Strode [halfline] 2013-12-11 17:20:47 EST
ah okay, probably the accountsservice issue then.

*** This bug has been marked as a duplicate of bug 1029195 ***

Note You need to log in before you can comment on or make changes to this bug.