Bug 1024211 - AttributeError: 'DeviceFormat' object has no attribute 'peStart'
AttributeError: 'DeviceFormat' object has no attribute 'peStart'
Status: CLOSED DUPLICATE of bug 896667
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:9644cab46eed2b990359963137d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 02:59 EDT by Peto
Modified: 2014-02-28 17:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-28 17:53:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (839.84 KB, text/plain)
2013-10-29 03:00 EDT, Peto
no flags Details
File: anaconda.log (62.36 KB, text/plain)
2013-10-29 03:00 EDT, Peto
no flags Details
File: environ (525 bytes, text/plain)
2013-10-29 03:00 EDT, Peto
no flags Details
File: lsblk_output (2.27 KB, text/plain)
2013-10-29 03:00 EDT, Peto
no flags Details
File: messages (233.41 KB, text/plain)
2013-10-29 03:00 EDT, Peto
no flags Details
File: nmcli_dev_list (14.27 KB, text/plain)
2013-10-29 03:00 EDT, Peto
no flags Details
File: os_info (179 bytes, text/plain)
2013-10-29 03:00 EDT, Peto
no flags Details
File: program.log (63.18 KB, text/plain)
2013-10-29 03:00 EDT, Peto
no flags Details
File: storage.log (390.95 KB, text/plain)
2013-10-29 03:00 EDT, Peto
no flags Details
File: ifcfg.log (1.05 KB, text/plain)
2013-10-29 03:00 EDT, Peto
no flags Details

  None (edit)
Description Peto 2013-10-29 02:59:55 EDT
Version-Release number of selected component:
anaconda-19.30.13-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2368, in size
    size += max(0, self.align(pv.size - pv.format.peStart))
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2385, in freeSpace
    log.debug("%s size is %dMB" % (self.name, self.size))
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 1926, in growLVM
    total_free = vg.freeSpace
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 306, in doAutoPartition
    growLVM(storage)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 241, in execute
    doAutoPartition(storage, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1644, in doKickstartStorage
    ksdata.autopart.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 393, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'DeviceFormat' object has no attribute 'peStart'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=LIVE rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-blivet-0.17-1.fc19.noarch, python-libs-2.7.5-1.fc19.x86_64
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Potential duplicate: bug 896667
Comment 1 Peto 2013-10-29 03:00:02 EDT
Created attachment 816979 [details]
File: anaconda-tb
Comment 2 Peto 2013-10-29 03:00:06 EDT
Created attachment 816980 [details]
File: anaconda.log
Comment 3 Peto 2013-10-29 03:00:10 EDT
Created attachment 816981 [details]
File: environ
Comment 4 Peto 2013-10-29 03:00:14 EDT
Created attachment 816982 [details]
File: lsblk_output
Comment 5 Peto 2013-10-29 03:00:18 EDT
Created attachment 816983 [details]
File: messages
Comment 6 Peto 2013-10-29 03:00:22 EDT
Created attachment 816984 [details]
File: nmcli_dev_list
Comment 7 Peto 2013-10-29 03:00:25 EDT
Created attachment 816985 [details]
File: os_info
Comment 8 Peto 2013-10-29 03:00:30 EDT
Created attachment 816986 [details]
File: program.log
Comment 9 Peto 2013-10-29 03:00:35 EDT
Created attachment 816987 [details]
File: storage.log
Comment 10 Peto 2013-10-29 03:00:39 EDT
Created attachment 816988 [details]
File: ifcfg.log
Comment 11 David Shea 2014-02-28 17:53:53 EST

*** This bug has been marked as a duplicate of bug 896667 ***

Note You need to log in before you can comment on or make changes to this bug.