Bug 1024215 - QMP query-cpus returns wrong value for PC
QMP query-cpus returns wrong value for PC
Status: CLOSED DUPLICATE of bug 612816
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Laszlo Ersek
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 03:05 EDT by Xiaoqing Wei
Modified: 2013-12-17 12:30 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1039804 (view as bug list)
Environment:
Last Closed: 2013-12-17 12:14:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoqing Wei 2013-10-29 03:05:48 EDT
Description of problem:

qmp and hmp uses different type on printing values

Version-Release number of selected component (if applicable):

qemu-kvm-0.12.1.2-2.414.el6.x86_64

How reproducible:
only once

Steps to Reproduce:
1. boot a vm
/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/virt/qemu/qemu \
    -S \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -chardev socket,id=hmp_id_humanmonitor1,path=/tmp/monitor-humanmonitor1-20131015-012233-iZ1IPwWu,server,nowait \
    -mon chardev=hmp_id_humanmonitor1,mode=readline \
    -chardev socket,id=qmp_id_qmp1,path=/tmp/monitor-qmp1-20131015-012233-iZ1IPwWu,server,nowait \
    -mon chardev=qmp_id_qmp1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20131015-012233-iZ1IPwWu,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20131015-012233-iZ1IPwWu,path=/tmp/seabios-20131015-012233-iZ1IPwWu,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20131015-012233-iZ1IPwWu,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,addr=0x5 \
    -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/virt/shared/data/images/win2012-64.qcow2',if=none,id=virtio-scsi0-id0,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device scsi-hd,drive=virtio-scsi0-id0 \
    -device e1000,netdev=idDeKoOZ,mac='9a:ea:eb:ec:ed:ee',bus=pci.0,addr=0x3,id='idENiJZg' \
    -netdev tap,id=idDeKoOZ,fd=27 \
    -m 2048 \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 \
    -cpu 'Penryn' \
    -M rhel6.5.0 \
    -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso',if=none,id=virtio-scsi1-id1,media=cdrom,readonly=on,format=raw \
    -device scsi-cd,drive=virtio-scsi1-id1 \
    -device AC97,addr=0x6 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -vnc :0 \
    -vga std \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off  \
    -enable-kvm

2.
2013-10-15 01:29:18: {"execute": "query-status", "id": "XNm6TDpe"}
2013-10-15 01:29:18: {"return": {"status": "prelaunch", "singlestep": false, "running": false}, "id": "XNm6TDpe"}
2013-10-15 01:30:12: {"timestamp": {"seconds": 1381771758, "microseconds": 823337}, "event": "RESUME"}
2013-10-15 01:30:12: {"execute": "query-cpus", "arguments": {}, "id": "8z5q7FNS"}
2013-10-15 01:30:12: {"return": [{"current": true, "CPU": 0, "pc": -8793413345313, "halted": true, "thread_id": 12062}, {"current": false, "CPU": 1, "pc": -8793413345313, "halted": true, "thread_id": 12063}], "id": "8z5q7FNS"}


2013-10-15 01:30:10: info status
2013-10-15 01:30:10: VM status: running
2013-10-15 01:30:10: (qemu) 
2013-10-15 01:30:10: screendump /dev/shm/scrdump-h6UW5R.ppm
2013-10-15 01:30:10: (qemu) 
2013-10-15 01:30:12: info cpus
2013-10-15 01:30:12: * CPU #0: pc=0xfffff8009fb89fdf (halted) thread_id=12062 
2013-10-15 01:30:12:   CPU #1: pc=0xfffff8009fb89fdf (halted) thread_id=12063 
2013-10-15 01:30:12: (qemu) 
2013-10-15 01:30:15: info status
2013-10-15 01:30:15: VM status: running




3.

Actual results:
values(pc) printed via hmp and qmp are diff

Expected results:
values should be identical via diff monitor type

Additional info:


Looked like one uses unsigned and another monitor isn't.
Comment 3 RHEL Product and Program Management 2013-11-01 04:25:08 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Amos Kong 2013-12-16 23:15:38 EST
duplicated with bz 612816?
Comment 5 Xiaoqing Wei 2013-12-17 00:54:12 EST
(In reply to Amos Kong from comment #4)
> duplicated with bz 612816?

Hi Amos,

Looks like.

Regards,
Xiaoqing Wei.
Comment 6 Laszlo Ersek 2013-12-17 12:14:05 EST
Agreed, closing as such. Thanks!

*** This bug has been marked as a duplicate of bug 612816 ***

Note You need to log in before you can comment on or make changes to this bug.