Bug 1024222 - need to clean xkb layouts from anaconda
need to clean xkb layouts from anaconda
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 03:22 EDT by anish
Modified: 2015-04-12 19:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-29 10:16:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (74.63 KB, image/png)
2013-10-29 03:22 EDT, anish
no flags Details

  None (edit)
Description anish 2013-10-29 03:22:44 EDT
Created attachment 816990 [details]
screen shot

Description of problem:
For Indian languages,most of the input methods are m17n libraries.
But anaconda shows xkb layouts which apprently confusing


Version-Release number of selected component (if applicable):
Fedora 20 TC -6 Beta

How reproducible:


Steps to Reproduce:
1. From Fedora 20 TC 6 beta, in installer select Marathi language
2. in installers keyboard settings menu, search india 


Actual results:
You could see Bengali language and India(Indian) language 
Please find screenshot attached 

Expected results:
When user selects installer in Marathi and then when he sees English keyboard as selected as default keyboard because of that he searches availble layouts for country then only Bengli langauge shows up. This behaviour is inconsistent with UI.
Also India(Indian) shows I am not sure what that mean

For better user and consistent user experience i think we should black list some of the xkb layouts 

Additional info:
Comment 1 David Shea 2013-10-29 10:16:54 EDT
Searching for a keyboard layout searches among all available layouts, not just the ones for the selected language. If you believe that the default keyboard layout set for your language is inappropriate, please file a bug against langtable.

Note You need to log in before you can comment on or make changes to this bug.