Bug 1024246 - Getting Started guide says GRE is supported, kernel doesn't support GRE
Getting Started guide says GRE is supported, kernel doesn't support GRE
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 4.0
Assigned To: Don Howard
Jean-Tsung Hsiao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 04:27 EDT by ben-redhat
Modified: 2013-10-30 18:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 18:55:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ben-redhat 2013-10-29 04:27:08 EDT
Description of problem:

During the packstack interactive section of the Getting Started Guide it says

"Choose this option if you wish to have configurable ports on a managed switch or will require VLAN or GRE support"

"The Open vSwitch Quantum plugin supports GRE tunneling, and you can select gre as long as the installed kernel (version 3.11 or later) and Open vSwitch userspace support GRE tunneling too."

In the table it does say:

"Supported values are local and vlan."

It looks like the kernel that ships with OpenStack does not support GRE.

Version-Release number of selected component (if applicable):

root@rhcontrol ~(keystone_admin)]# uname -a
Linux rhcontrol 2.6.32-358.118.1.openstack.el6.x86_64 #1 SMP Wed Aug 14 13:18:08 EDT 2013 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:


Steps to Reproduce:
1. Install packstack and select gre for network_type.
2.
3.

Actual results:
GRE doesn't work.

Expected results:
GRE to work.

Additional info:

The quantum openvswitch error that shows the kernel does not support gre:

2013-10-28 19:22:26    ERROR [quantum.plugins.openvswitch.agent.ovs_quantum_agent] Failed to create OVS patch port. Cannot have tunneling enabled on this agent, since this version of OVS does not support tunnels or patch ports. Agent terminated!

One of the two should be done:

A) The installer should not allow installing gre if it won't work and the Getting Started guide should be clear that the kernel provided does not support gre.

B) Provide instructions on how to change the kernel to one that does support gre.  The RDO version of Open Stack provides these instructions.
Comment 2 Thomas Graf 2013-10-29 04:41:53 EDT
(In reply to ben-redhat from comment #0)
> root@rhcontrol ~(keystone_admin)]# uname -a
> Linux rhcontrol 2.6.32-358.118.1.openstack.el6.x86_64 #1 SMP Wed Aug 14
> 13:18:08 EDT 2013 x86_64 x86_64 x86_64 GNU/Linux

This kernel does support GRE. What version of openvswitch do you have
installed? You will require at least 1.11 to have GRE capabilities.
Comment 3 ben-redhat 2013-10-29 20:45:25 EDT
OK, then it looks like the version of openvswitch is the issue, but either way it does not look like RHOS Enterprise 3.0 Grizzly supports GRE.

[root@rhcontrol ~]# rpm -q -a | grep "vswitch"
openvswitch-1.9.0-2.el6ost.x86_64
openstack-quantum-openvswitch-2013.1.3-1.el6ost.noarch

[root@rhcontrol ~]# ovs-vsctl -V
ovs-vsctl (Open vSwitch) 1.9.0
Compiled Jun  3 2013 10:40:50
Comment 4 Jean-Tsung Hsiao 2013-10-29 21:07:15 EDT
(In reply to ben-redhat from comment #3)
> OK, then it looks like the version of openvswitch is the issue, but either
> way it does not look like RHOS Enterprise 3.0 Grizzly supports GRE.
> 
> [root@rhcontrol ~]# rpm -q -a | grep "vswitch"
> openvswitch-1.9.0-2.el6ost.x86_64
> openstack-quantum-openvswitch-2013.1.3-1.el6ost.noarch
> 
> [root@rhcontrol ~]# ovs-vsctl -V
> ovs-vsctl (Open vSwitch) 1.9.0
> Compiled Jun  3 2013 10:40:50

You can find openvswitch-1.11.0-1.el6.x86_64.rpm in Grizzly/latest.
Comment 5 ben-redhat 2013-10-30 17:15:12 EDT
Thanks, I just did a yum update and it picked up the new version.  Somehow the Folsom repo had gotten re-enabled, I am not sure how (I know I had disabled it) and I had last done a yum update on the 28th.  The Grizzly depo was still set for priority 1 so it should have had priority anyways.  But either way, the new openvswitch was picked up.

Updating:
 device-mapper          x86_64 1.02.77-9.el6_4.2 rhel-6-server-rpms       145 k
 device-mapper-event    x86_64 1.02.77-9.el6_4.2 rhel-6-server-rpms        97 k
 device-mapper-event-libs
                        x86_64 1.02.77-9.el6_4.2 rhel-6-server-rpms        91 k
 device-mapper-libs     x86_64 1.02.77-9.el6_4.2 rhel-6-server-rpms       173 k
 gnupg2                 x86_64 2.0.14-6.el6_4    rhel-6-server-rpms       1.6 M
 libgcrypt              x86_64 1.4.5-11.el6_4    rhel-6-server-rpms       229 k
 lvm2                   x86_64 2.02.98-9.el6_4.2 rhel-6-server-rpms       655 k
 lvm2-libs              x86_64 2.02.98-9.el6_4.2 rhel-6-server-rpms       712 k
 openvswitch            x86_64 1.11.0-1.el6      rhel-server-ost-6-3-rpms 1.8 M
 spice-server           x86_64 0.12.0-12.el6_4.5 rhel-6-server-rpms       327 k

GRE is fully working now. The VMs appear to have full network connectivity in and out.

I honestly don't know if this was a repo issue on my end or whether you just released the new openvswitch that fixed this issue, but it is fixed now.
Comment 6 Thomas Graf 2013-10-30 18:55:25 EDT
(In reply to ben-redhat from comment #5)
> Thanks, I just did a yum update and it picked up the new version.  Somehow
> the Folsom repo had gotten re-enabled, I am not sure how (I know I had
> disabled it) and I had last done a yum update on the 28th.  The Grizzly depo
> was still set for priority 1 so it should have had priority anyways.  But
> either way, the new openvswitch was picked up.
> 
> Updating:
>  device-mapper          x86_64 1.02.77-9.el6_4.2 rhel-6-server-rpms      
> 145 k
>  device-mapper-event    x86_64 1.02.77-9.el6_4.2 rhel-6-server-rpms       
> 97 k
>  device-mapper-event-libs
>                         x86_64 1.02.77-9.el6_4.2 rhel-6-server-rpms       
> 91 k
>  device-mapper-libs     x86_64 1.02.77-9.el6_4.2 rhel-6-server-rpms      
> 173 k
>  gnupg2                 x86_64 2.0.14-6.el6_4    rhel-6-server-rpms      
> 1.6 M
>  libgcrypt              x86_64 1.4.5-11.el6_4    rhel-6-server-rpms      
> 229 k
>  lvm2                   x86_64 2.02.98-9.el6_4.2 rhel-6-server-rpms      
> 655 k
>  lvm2-libs              x86_64 2.02.98-9.el6_4.2 rhel-6-server-rpms      
> 712 k
>  openvswitch            x86_64 1.11.0-1.el6      rhel-server-ost-6-3-rpms
> 1.8 M
>  spice-server           x86_64 0.12.0-12.el6_4.5 rhel-6-server-rpms      
> 327 k
> 
> GRE is fully working now. The VMs appear to have full network connectivity
> in and out.
> 
> I honestly don't know if this was a repo issue on my end or whether you just
> released the new openvswitch that fixed this issue, but it is fixed now.

Thanks for the prompt feedback! Let us know if you have any further issues.

Note You need to log in before you can comment on or make changes to this bug.