Bug 1024303 - does not start with bzr-2.6
does not start with bzr-2.6
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bzr-explorer (Show other bugs)
20
noarch Linux
unspecified Severity high
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 07:16 EDT by Jiri Popelka
Modified: 2013-11-10 02:58 EST (History)
1 user (show)

See Also:
Fixed In Version: bzr-explorer-1.3.0-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 02:58:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Popelka 2013-10-29 07:16:18 EDT
Version-Release number of selected component (if applicable):
bzr-2.6.0-2.fc20.x86_64
bzr-explorer-1.2.2-4.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1. bzr explorer

Actual results:
bzr: ERROR: exceptions.ImportError: cannot import name cmd_launchpad_open

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/bzrlib/commands.py", line 930, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/commands.py", line 1121, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib64/python2.7/site-packages/bzrlib/commands.py", line 673, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib64/python2.7/site-packages/bzrlib/commands.py", line 697, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/cleanup.py", line 136, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/cleanup.py", line 166, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/bzrlib/plugins/explorer/lib/commands.py", line 161, in run
    window = explorer.QExplorerMainWindow(location_list=location_list,
  File "/usr/lib64/python2.7/site-packages/bzrlib/lazy_import.py", line 108, in __getattribute__
    obj = object.__getattribute__(self, '_resolve')()
  File "/usr/lib64/python2.7/site-packages/bzrlib/lazy_import.py", line 85, in _resolve
    obj = factory(self, scope, name)
  File "/usr/lib64/python2.7/site-packages/bzrlib/lazy_import.py", line 200, in _import
    module = __import__(module_python_path, scope, scope, [member], level=0)
  File "/usr/lib/python2.7/site-packages/bzrlib/plugins/explorer/lib/explorer.py", line 32, in <module>
    from bzrlib.plugins.explorer.lib import (
  File "/usr/lib/python2.7/site-packages/bzrlib/plugins/explorer/lib/hosted_url_resolver.py", line 21, in <module>
    from bzrlib.plugins.launchpad import cmd_launchpad_open
ImportError: cannot import name cmd_launchpad_open

bzr 2.6.0 on python 2.7.5 (Linux-3.11.6-301.fc20.x86_64-x86_64-with-
    fedora-20-Heisenbug)
arguments: ['/bin/bzr', 'explorer']
plugins: bash_completion[2.6.0], bzrtools[2.5.0], changelog_merge[2.6.0],
    explorer[1.2.2], grep[2.6.0], launchpad[2.6.0],
    netrc_credential_store[2.6.0], news_merge[2.6.0], po_merge[2.6.0],
    qbzr[0.23.1], weave_fmt[2.6.0]
encoding: 'utf-8', fsenc: 'UTF-8', lang: 'en_US.UTF-8'

*** Bazaar has encountered an internal error.  This probably indicates a
    bug in Bazaar.  You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.

Expected results:
It starts.

Additional info:
As far as I understand
https://bugs.launchpad.net/bzr-explorer/+bug/962671
this should have been already fixed upstream, but no new version has been released since then.
Comment 1 Toshio Ernie Kuratomi 2013-10-29 19:53:29 EDT
I found a new release that references that bug.  I've built it and will push it for f20 now.  Could you test it?  I don't have a non-headless F20 box right now.
Comment 2 Fedora Update System 2013-10-29 19:55:22 EDT
bzr-explorer-1.3.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/bzr-explorer-1.3.0-1.fc20
Comment 3 Fedora Update System 2013-10-30 13:10:12 EDT
Package bzr-explorer-1.3.0-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bzr-explorer-1.3.0-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20309/bzr-explorer-1.3.0-1.fc20
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-11-10 02:58:42 EST
bzr-explorer-1.3.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.