Bug 1024305 - (DownloadTracker) Review and update http://zanata.org/download/ documentation
Review and update http://zanata.org/download/ documentation
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Docs (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Alex Eng
Damian Jansen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 07:18 EDT by David O'Brien
Modified: 2016-01-20 20:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 20:40:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David O'Brien 2013-10-29 07:18:58 EDT
Description of problem:

A few things to look at:
- Check for prerequisites or important conceptual or reference material
- Review for style and consistency
- Identify and fix any factual errors, incorrect paths, etc.
- Identify any missing steps or other info that would prevent a successful installation.

Version-Release number of selected component (if applicable):


Expected results:

- Writing style consistent with Red Hat Style Guide as much as possible (Zanata is a community project and some variations are acceptable)
- No factual errors
- No missing information
- No broken links

Additional info:

This bug may end up being a tracker for smaller bugs on this page.
Comment 1 Ding-Yi Chen 2013-10-30 04:40:02 EDT
Hi,

Just couple of things:

In section Prerequisites:
How about adding:
Database such as MySQL (which is not included in the zip)
Database java connector (mysql-java-connector) (which is included in the zip).

There are several optional packages:
1. clamav for antivirus
2. Fonts for CAPTCHA and server monitoring diagrams.

In section "Configuring Zanata", item 4, do you think showing the whole tag more readable? e.g.

<simple name="java:global/zanata/email/default-from-address" value="admin@example.com"/>

In section "Configuring Zanata", item 5, besides the format suggested in earlier paragraph, in FireFox it looks like:


java:global/zanata/smtp/host java:global/zanata/smtp/port java:global/zanata/smtp/username java:global/zanata/smtp/password java:global/zanata/smtp/tls java:global/zanata/smtp/ssl 


Which is not very readable.


In Section Starting the Zanata Server:
If cwd is not <ZANATA DIR>/bin/, then it won't work.
Instead, use following command:

cd <ZANATA DIR>/bin; ./start-zanata.sh


Regards,
Comment 2 David O'Brien 2013-10-30 05:46:20 EDT
b3103eb..96eadeb  master -> master

Includes all of the above fixes, but I wasn't sure what to do about the Windows version "start-zanata". Does that require similar treatment?

thanks for the review.

David
Comment 3 Ding-Yi Chen 2013-10-30 23:05:43 EDT
(In reply to David O'Brien from comment #2)
> b3103eb..96eadeb  master -> master
> 
> Includes all of the above fixes, but I wasn't sure what to do about the
> Windows version "start-zanata". Does that require similar treatment?

Yes. it would be 
cd <ZANATA DIR>\bin
start-zanata.bat

Oh, I forget to mention:
In Configuring Zanata, item 5
Those properties are included standalone.xml.
You need to add them between:

<subsystem xmlns="urn:jboss:domain:naming:1.3">
            <bindings>
                ....
            </bindings>
</subsystem>

The same place that you put 
<simple name="java:global/zanata/security/admin-users" value="admin"/>
and 
<simple name="java:global/zanata/email/default-from-address" value="admin@example.com"/>

Regards
Comment 4 Alex Eng 2015-05-25 23:41:44 EDT
Updated documentation for downloads: 

http://docs.zanata.org/en/latest/user-guide/systemadmin/configuration/installation/index.html

I think all the instructions in zanata.org/download should move to http://docs.zanata.org/en/latest/user-guide/systemadmin/configuration/installation/index.html and have just download links of various version of Zanata package.
Comment 5 Alex Eng 2015-06-08 18:24:42 EDT
Pull request:
https://github.com/zanata/zanata.github.io/pull/25
Comment 6 Damian Jansen 2015-06-08 18:55:08 EDT
"Verified" at bf0cc1cb54b30648f520fbfcaffa3631dad52945

Note You need to log in before you can comment on or make changes to this bug.