Bug 1024310 - Support conversion of guest using grub2
Support conversion of guest using grub2
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.5
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 07:22 EDT by tingting zheng
Modified: 2014-11-18 06:24 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-18 06:24:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tingting zheng 2013-10-29 07:22:12 EDT
Description
Support conversion of guest using grub2

Version:
libvirt-1.1.1-10.el7.x86_64
virt-v2v-0.9.1-4.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.Prepare a fedora 19 guest which using grub2.

2.Use virt-v2v to convert it.
# virt-v2v -ic qemu+ssh://10.66.72.24/system -os default grub2-test
grub2-test.img: 100% [=================================================================================]D 0h03m32s
Didn't find modules directory /lib/modules/0-rescue-030b8ef508f9c11e5a76aaed048f5bbc for kernel /boot/vmlinuz-0-rescue-030b8ef508f9c11e5a76aaed048f5bbc
Use of uninitialized value $version in concatenation (.) or string at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm line 1138.
Use of uninitialized value $kernel in concatenation (.) or string at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm line 2470.
virtio configured, but no virtio kernel found at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm line 1007.


Actual results:
As description.

Expected results:
virt-v2v can convert guests using grub2

Additional info:
Comment 3 tingting zheng 2014-02-24 04:30:30 EST
Bug 1059386 also hit the same error.
So I think the error is caused by something in grub conf which virt-v2v doesn't aware.
Comment 5 Cui Lei 2014-03-12 04:59:56 EDT
Hi, Matthew
Help uday make a needinfo to you. 
Please take a while to consider if we support guest conversion with grub2 or any other grub setting in RHEL6.6

Regards,
Lei
Comment 7 Matthew Booth 2014-03-31 05:40:55 EDT
The root cause here is that _inspect_linux_kernel can return undef if it can't identify useful information about the kernel, but nowhere that calls it handles this.
Comment 8 Richard W.M. Jones 2014-11-18 06:24:34 EST
Virt-v2v needs to run on the latest Red Hat Enterprise Linux release
to ensure it can correctly read and modify new guest filesystem
features.  A new version of virt-v2v is now available for RHEL 7.1.

Before RHEL 7.1 is released, follow the instructions here to
install unsupported preview packages on top of RHEL 7.0:
https://www.redhat.com/archives/libguestfs/2014-May/msg00090.html

After RHEL 7.1 is released, virt-v2v will be available in
Technical Preview.

You can run virt-v2v in a single virtual machine.  Other
requirements are covered here:
http://libguestfs.org/virt-v2v.1.html#resource-requirements

If you find a missing feature or bug in the new version of virt-v2v
please file a bug using the following link:
https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%207&component=libguestfs

Note You need to log in before you can comment on or make changes to this bug.