Bug 1024314 - Issues reconnecting when accessing mail via VPN
Issues reconnecting when accessing mail via VPN
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 1037977 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 07:28 EDT by Peter Robinson
Modified: 2015-01-06 18:28 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 12:50:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 722280 None None None Never

  None (edit)
Description Peter Robinson 2013-10-29 07:28:27 EDT
In Fedora 19 and all releases prior that I can remember I could suspend my laptop, have the VPN disconnect and at a later point resume, reconnect to the VPN (or if in the office connect to the TFA authed WiFi) and have Evolution reconnect to the mail server and continue as before.

Now if I try to do that it just sits there trying to pull mail. I have to run a "evolution --force-shutdown" and start it up again before it will reconnect with the mail server. All other services behind the VPN work as expected, and evolution, once restarted, does as well. It just use to be that I could hit F-12 and it would pull down and I would continue as I did before.
Comment 1 Milan Crha 2013-11-05 06:13:28 EST
Thanks for a bug report. Could you provide a backtrace of evolution in that state, please? Once we figure out some more details I'd move this upstream (or we can straight away, if you wish).
Comment 2 Peter Robinson 2013-11-05 07:01:24 EST
I know how to grab a BT of stuff when it's crashing but not sure with evo with it's numerous processes (e-d-s vs evo) when it's running normally. Is there an overview of this?
Comment 3 Milan Crha 2013-11-05 10:17:47 EST
It's not an exact science, it's sometimes worthless to get backtraces for other evolution processes, all depends on circumstances. I wanted to start with evolution itself, because all the mail is handled there. We can follow base don the backtrace state to other processes, if needed.

By the way, due to sever regressions found in bug #1022750, I reverted one patch from evolution-data-server in Fedora 19. The change is currently in updates testing [1], maybe it's related to your issue, maybe not.

[1] https://admin.fedoraproject.org/updates/evolution-data-server-3.8.5-6.fc19
Comment 4 David Dreggors 2014-01-02 12:42:01 EST
Just confirming...

I have the same issue (I think) in Fedora 20. The version of evolution/evolution-data-server I have is:

evolution-data-server-3.10.3-1.fc20.x86_64
evolution-3.10.3-1.fc20.x86_64


If I have evolution open when I connect to my work VPN with openconnect it just spins while trying to get mail.

If I close evolution and reopen, it works fine again.
Comment 5 Milan Crha 2014-01-15 12:50:30 EST
I think it's some kind of regression in 3.10.x, thus I moved this upstream finally, as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=722280
Comment 6 Milan Crha 2014-01-15 13:14:41 EST
*** Bug 1037977 has been marked as a duplicate of this bug. ***
Comment 7 David Dreggors 2014-01-15 22:07:00 EST
The answer upstream is:

"This should work better in 3.12, where each email account now manages its own
online/offline state with the help of GNetworkMonitor."


How soon can we see 3.12.x in Fedora?
Comment 8 Milan Crha 2014-01-16 03:10:19 EST
(In reply to David Dreggors from comment #7)
> How soon can we see 3.12.x in Fedora?

3.12 will be part of Fedora 21. Nonetheless, I run that development version and I also see issues on reconnecting, thus the 3.12 (actually 3.11.4) doesn't have it done better yet.
Comment 9 Matthew Saltzman 2015-01-06 18:28:51 EST
Still not done in evolution-ews-3.12.9-1.fc21.x86_64, just FYI.

Note You need to log in before you can comment on or make changes to this bug.