Bug 1024335 - Manpage doesn't document -drive rerror/werror/readonly
Manpage doesn't document -drive rerror/werror/readonly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks: 1090362
  Show dependency treegraph
 
Reported: 2013-10-29 08:30 EDT by Kevin Wolf
Modified: 2014-10-14 02:53 EDT (History)
11 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.420.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1090362 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:53:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Wolf 2013-10-29 08:30:07 EDT
The qemu manpage in RHEL 6 doesn't document the rerror/werror/readonly options
for -drive, even though these options are implemented. They should be added to
the manpage.
Comment 1 Miroslav Rezanina 2014-01-27 02:51:03 EST
Fix included in qemu-kvm-0.12.1.2-2.420.el6
Comment 3 Chao Yang 2014-07-01 01:54:21 EDT
Steps to reproduce and verify this issue:
1. dump output of man qemu-kvm for fixed qemu-kvm and unfixed qemu-kvm
2. run diff on them

Tested with qemu-kvm-0.12.1.2-2.428.el6.x86_64 and qemu-kvm-0.12.1.2-2.415.el6.x86_64. Actual result is as below:

# diff -up qemu-kvm-man-old qemu-kvm-man
--- qemu-kvm-man-old	2014-07-01 13:49:01.385203252 +0800
+++ qemu-kvm-man	2014-07-01 13:43:02.638202102 +0800
@@ -168,6 +168,17 @@ OPTIONS
 	   addr=addr
 	       Specify the controller’s PCI address (if=virtio only).
 
+	   werror=action,rerror=action
+	       Specify which action to take on write and read errors. Valid
+	       actions are: "ignore" (ignore the error and try to continue),
+	       "stop" (pause QEMU), "report" (report the error to the guest),
+	       "enospc" (pause QEMU only if the host disk is full; report the
+	       error to the guest otherwise).  The default setting is
+	       werror=enospc and rerror=report.
+
+	   readonly
+	       Open drive file as read-only. Guest write attempts will fail.
+


As per above, this issue has been fixed.
Comment 4 errata-xmlrpc 2014-10-14 02:53:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1490.html

Note You need to log in before you can comment on or make changes to this bug.