Bug 1024337 - Overflow in nsslapd-disk-monitoring-threshold on i686
Overflow in nsslapd-disk-monitoring-threshold on i686
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rich Megginson
Sankar Ramalingam
:
Depends On:
Blocks: 1061410
  Show dependency treegraph
 
Reported: 2013-10-29 08:37 EDT by Ján Rusnačko
Modified: 2014-10-14 03:51 EDT (History)
5 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-34.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:51:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ján Rusnačko 2013-10-29 08:37:10 EDT
Versions affected: 
389-ds-base-1.2.11.15-22.el6_4.i686 (RHEL 6.4)
389-ds-base-1.2.11.15-29.el6.i686 (RHEL 6.5)

Versions not affected:
389-ds-base-1.2.11.15-22.el6_4.x86_64 (RHEL 6.4)
389-ds-base-1.2.11.15-29.el6.x86_64 (RHEl 6.5)


How reproducible:

On 32bit RHEL 6.5:
[jrusnack@dstet ~]$ ldapsearch -D "cn=directory manager" -w Secret123 -b "cn=config" -LLL nsslapd-disk-monitoring-threshold -s base
dn: cn=config
nsslapd-disk-monitoring-threshold: 2097152

[jrusnack@dstet ~]$  ldapmodify -D "cn=directory manager" -w Secret123 <<EOF
> dn: cn=config
> changetype: modify
> replace: nsslapd-disk-monitoring-threshold
> nsslapd-disk-monitoring-threshold: 3000000000
> EOF
modifying entry "cn=config"

[jrusnack@dstet ~]$ ldapsearch -D "cn=directory manager" -w Secret123 -b "cn=config" -LLL nsslapd-disk-monitoring-threshold -s base
dn: cn=config
nsslapd-disk-monitoring-threshold: -1294967296

[jrusnack@dstet ~]$ rpm -qa | grep 389-ds-base
389-ds-base-libs-1.2.11.15-29.el6.i686
389-ds-base-1.2.11.15-29.el6.i686

On 64bit RHEL 6.5:
[jrusnack@dstet ~]$  ldapsearch -D "cn=directory manager" -w Secret123 -b "cn=config" -LLL nsslapd-disk-monitoring-threshold -s base
dn: cn=config
nsslapd-disk-monitoring-threshold: 2097152

[jrusnack@dstet ~]$  ldapmodify -D "cn=directory manager" -w Secret123 <<EOF
> dn: cn=config
> changetype: modify
> replace: nsslapd-disk-monitoring-threshold
> nsslapd-disk-monitoring-threshold: 3000000000
> EOF
modifying entry "cn=config"

[jrusnack@dstet ~]$  ldapsearch -D "cn=directory manager" -w Secret123 -b "cn=config" -LLL nsslapd-disk-monitoring-threshold -s base
dn: cn=config
nsslapd-disk-monitoring-threshold: 3000000000

[jrusnack@dstet ~]$ rpm -qa | grep 389-ds-base
389-ds-base-libs-1.2.11.15-29.el6.x86_64
389-ds-base-1.2.11.15-29.el6.x86_64
Comment 1 Ján Rusnačko 2013-10-29 08:38:48 EDT
Credits for finding the bug to Sankar Ramlingam.
Comment 3 Nathan Kinder 2013-12-18 11:36:34 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/47638
Comment 4 mreynolds 2014-01-24 10:59:41 EST
Fixed upstream
Comment 7 errata-xmlrpc 2014-10-14 03:51:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1385.html

Note You need to log in before you can comment on or make changes to this bug.