Bug 1024351 - Neutron dhcp again says the dnsmasq is too old.
Neutron dhcp again says the dnsmasq is too old.
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 4.0
Assigned To: RHOS Maint
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 09:17 EDT by Attila Fazekas
Modified: 2016-04-26 22:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 07:14:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Tomáš Hozza 2013-10-29 09:55:22 EDT
What exactly you expect from me to do about it? Don't expect I'll rebase dnsmasq
to 2.59 in RHEL-6 just because some dhcp (client/server) prints warning.
Comment 3 Tomáš Hozza 2013-10-29 10:01:23 EDT
I'm curious why is dnsmasq component tracked in RHOS product. AFAIK dnsmasq is
part of RHEL product and all issues are tracked there. Also any updates to
dnsmasq have to go through RHEL update workflow. So untill dnsmasq is packaged
separately and distributed with RHOS only I don't see any reason why it should
be so.
Comment 4 Attila Fazekas 2013-10-29 11:14:46 EDT
According to this bug https://bugs.launchpad.net/neutron/+bug/1170793 prior the the 0.59 version,  multiple bugs can occur related to the dnsmasq.

I would recommend to upgrade dnsmasq  >=0.59 in the openstack repositories, if all related bug fix is backported, the warning should be removed.
Comment 5 Tomáš Hozza 2013-10-29 14:27:41 EDT
(In reply to Attila Fazekas from comment #4)
> According to this bug https://bugs.launchpad.net/neutron/+bug/1170793 prior
> the the 0.59 version,  multiple bugs can occur related to the dnsmasq.
> 
> I would recommend to upgrade dnsmasq  >=0.59 in the openstack repositories,
> if all related bug fix is backported, the warning should be removed.

1. I don't have any knowledge WHERE and HOW to update dnsmasq for RHOS. RHOS
   is using dnsmasq without me knowing the use case, where and how I can maintain
   it in the RHOS product. Next time RHOS is deciding on using some component it
   would be good to notify the particular maintainer so they at least know about
   it and know how to deal with issues in the product.

2. If the version available in RHEL-6 has some bugs, as you are saying, please
   create new Bugs with proper description for them in the RHEL product. Saying
   that there are multiple bugs without clearly knowing what they are is not
   useful at all.

From my point of view, I don't see anything that needs to be fixed in dnsmasq 
at the moment. Once you know what are those real issues, feel free to open bugs
for them. I'm changing the component to neutron, since this is the source of the
warning this bug is about.
Comment 6 lpeer 2013-11-06 07:14:33 EST
There is a requirement in u/s to use dnsmasq version > 2.59.

http://docs.openstack.org/trunk/openstack-network/admin/content/install_prereqs.html

There is also a patch that eliminates the need to get support in 'tag' and 'set' in dnsmasq which enables Neutron to run with 2.48 which is the version available in RHEL 6.4 and 6.5.

https://review.openstack.org/#/c/29083/

The warning is there because of the formal requirement in u/s but until we get any concrete issue with dnsmasq 2.48 I don't see a good reason to handle the overhead of shipping a special dnsmasq version in RHOS channels.
Comment 7 Tomáš Hozza 2013-11-06 08:15:09 EST
(In reply to lpeer from comment #6)
> The warning is there because of the formal requirement in u/s but until we
> get any concrete issue with dnsmasq 2.48 I don't see a good reason to handle
> the overhead of shipping a special dnsmasq version in RHOS channels.

As a dnsmasq maintainer I totally agree with you. I'm also prepared to discuss
possibility to fix specific bugs in dnsmasq or to include newer version as a
different package (in RHEL or RHOS) or to package dnsmasq using RHSCL.

Thanks for your very reasonable comment.

Note You need to log in before you can comment on or make changes to this bug.