This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1024352 - jboss-eap-bom-parent 6.2.0-build-7 still has picketlink version 2.1.6.3.Final-redhat-2
jboss-eap-bom-parent 6.2.0-build-7 still has picketlink version 2.1.6.3.Final...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: CR1
: EAP 6.2.0
Assigned To: Paul Gier
Vladimir Rastseluev
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 09:31 EDT by Peter Skopek
Modified: 2014-01-12 19:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:49:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Skopek 2013-10-29 09:31:38 EDT
JBoss EAP 6.2 is going to include PicketLink version 2.1.9.SP2-redhat-1.

EAP bom should include this version.

BOM GAV:
    <groupId>org.jboss.bom.eap</groupId>
    <artifactId>jboss-eap-bom-parent</artifactId>
    <version>6.2.0-build-7</version>
Comment 1 sgilda 2013-10-31 10:49:39 EDT
@pgier: Don't you change the 6.2.0-build-SNAPSHOT to the correct version during the build process?
Comment 2 sgilda 2013-10-31 10:50:05 EDT
See my comment above.
Comment 3 sgilda 2013-11-05 15:32:13 EST
Reassigning to Paul Gier since he does the BOMs for EAP 6.2.x. 

Paul, send it back if it's something I should take care of.
Comment 4 Paul Gier 2013-11-06 22:47:15 EST
Sande, yet the BOM version changes from 6.2.0-build-SNAPSHOT to the EAP target release version when it's added to the maven repo.

Peter, to update the version of picketlink in the BOM for 6.2.0, please send a PR to the 6.2.x branch of the jboss-eap-boms project.  We also normally review the BOM versions to verify that they are in sync with EAP before each ER.
Comment 5 Peter Skopek 2013-11-07 07:05:17 EST
Paul, I have check it. It is fine, right now.
Comment 6 Nikoleta Ziakova 2013-11-15 06:24:32 EST
jboss-eap-bom-parent-6.2.0.GA.pom includes PicketLink version 2.1.9.SP1-redhat-1:

<!-- Picketlink -->
<version.org.picketlink>2.1.9.SP1-redhat-1</version.org.picketlink>

This is the same version as is included in EAP binary distribution.

Verified for EAP 6.2.0 CR1.

Note You need to log in before you can comment on or make changes to this bug.