Bug 1024362 - Synced repo with i18n'd package groups shows translated description in all languages when you run rpm content
Synced repo with i18n'd package groups shows translated description in all la...
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
Master
Unspecified Unspecified
medium Severity unspecified
: ---
: 2.4.0
Assigned To: Barnaby Court
Preethi Thomas
: Triaged
: 1024364 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 10:06 EDT by Preethi Thomas
Modified: 2014-08-09 02:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1021656
Environment:
Last Closed: 2014-08-09 02:57:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2013-10-29 10:06:46 EDT
Description

When syncing repos with package groups that have been translated pulp-admin rpm repo content group shows Translated description in all languages


Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1.  Create a repo using epel as the feed url
2.  Sync the repo
3.  List the package groups

Actual results:

Translated Description which is very long 

Expected results:

May be we can remove the Translated description.


[root@ibm-x3550m3-11 ~]# pulp-admin rpm repo content group --repo-id rhel59-os |more
Conditional Package Names: 
Default:                   True
Default Package Names:     authconfig-gtk, pirut, sabayon, setroubleshoot,
                           system-config-date, system-config-kdump,
                           system-config-keyboard, system-config-language,
                           system-config-lvm, system-config-netboot,
                           system-config-network, system-config-rootpassword,
                           system-config-soundcard, system-config-users
Description:               This group is a collection of graphical
                           administration tools for the system, such as for
                           managing user accounts and configuring system
                           hardware.
Display Order:             1024
Id:                        admin-tools
Langonly:                  None
Mandatory Package Names:   
Name:                      Administration Tools
Optional Package Names:    system-config-kickstart, tunctl
Repo Id:                   rhel59-os
Translated Description:    
  Af:       Hierdie groep is 'n versameling grafiese administrasienutsgoed vir
            die rekenaar, byvoorbeeld vir die bestuur van gebruikersrekeninge en
            die opstelling van rekenaarhardeware.
  Am:       ይህ ቡድን ለሲስተሙ የንድፋዊ አስተዳደር
            መሣሪያ ለተጠቃሚው ታሪክ እና የሲስተሙን
            ሀርድዌር ማስተካከያ ስብስብ ነው።
  Ar:       تحتوي هذه المجموعة على أدوات ذات
            واجهة رسومية لإدارة النظام مثل إدارة
            حسابات المستخدمين و تهيئة عتاد
            النّظام.
  As:       এই দল চিস্টেমৰ বাবে
            গ্ৰাফীয় প্ৰশাসনিক
            সঁজুলিৰ সংগ্ৰহ, যেনে,
            ব্যৱহাৰকাৰীৰ হিচাপ-বহি
--More--
Comment 1 Preethi Thomas 2013-10-29 10:09:40 EDT
*** Bug 1024364 has been marked as a duplicate of this bug. ***
Comment 2 Randy Barlow 2013-10-30 08:00:56 EDT
I'm going to solve this by making it so the translated description is not shown by default. The user will still be able to retrieve it by explicitly requesting that field.
Comment 3 Randy Barlow 2013-10-30 09:00:19 EDT
It looks like this might be more of an RFE than a bug. As I look into the code that handles this, it appears that it was always this way. I'm going to put it back to NEW and wait until we triage it to decide whether we should do this for 2.3 or not.
Comment 4 Barnaby Court 2013-12-17 09:31:58 EST
This might have been fixed already by some other work in the client code.
Comment 5 Barnaby Court 2013-12-18 09:53:38 EST
Yup, just double checked, it has been fixed in the master branch.
Comment 6 Jeff Ortel 2014-04-03 09:36:31 EDT
build: 2.4.0-0.7.beta
Comment 7 Preethi Thomas 2014-04-21 18:39:40 EDT
verified
[root@dhcp129-52 ~]# rpm -qa pulp-server
pulp-server-2.4.0-0.9.beta.fc20.noarch
[root@dhcp129-52 ~]# 

[root@dhcp129-52 ~]# pulp-admin rpm repo content group --repo-id rhel5-9 |more
Conditional Package Names: 
Default Package Names:     authconfig-gtk, pirut, sabayon, setroubleshoot,
                           system-config-date, system-config-kdump,
                           system-config-keyboard, system-config-language,
                           system-config-lvm, system-config-netboot,
                           system-config-network, system-config-rootpassword,
                           system-config-soundcard, system-config-users
Description:               This group is a collection of graphical
                           administration tools for the system, such as for
                           managing user accounts and configuring system
                           hardware.
Id:                        admin-tools
Mandatory Package Names:   
Name:                      Administration Tools
Optional Package Names:    system-config-kickstart, tunctl
User Visible:              True
Comment 8 Randy Barlow 2014-08-09 02:57:09 EDT
This has been fixed in Pulp 2.4.0-1.

Note You need to log in before you can comment on or make changes to this bug.