Bug 102440 - Saving bookmarks to locally installed rhl-* docs gives not unique bookmark
Saving bookmarks to locally installed rhl-* docs gives not unique bookmark
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: rhl-cg (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Ha
Tammy Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-15 02:42 EDT by Karl-Olov Serrander
Modified: 2014-08-04 18:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-17 18:00:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl-Olov Serrander 2003-08-15 02:42:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Saving a bookmark in mozilla of rhl-cg-en-9-2 only gives a bookmark with title
"Red Hat Linux 9", and since i usually want to keep a list of all docs at hand I
have to edit every bookmark to give it a unique name.

Version-Release number of selected component (if applicable):
rhl-cg-en-9-2

How reproducible:
Always

Steps to Reproduce:
1. Open /usr/share/doc/rhl-cg-en-9-2/index.html
2. Bookmark this page
3. Look at the bookmark

Expected Results:  The bookmark should perhaps be named "Red Hat Linux 9
Customization Guide"

Additional info:
Comment 1 Tammy Fox 2003-10-07 12:39:26 EDT
This is because DocBook makes the title of the book the title of the HTML page.
Since all of the titles start with Red Hat Linux 9, this happens. I'll try to
figure out a way to change this behavior.
Comment 2 Tammy Fox 2004-02-27 00:44:20 EST
Changing owner to new owner
Comment 3 John Ha 2005-02-17 18:00:26 EST
Our current HTML publishing tools only display the product in the <title>
element of the title HTML page. Subsequent pages use the title of its associated
chapter as the <title> of the HTML document, and are more convenient to bookmark.

In the meantime, the bookmark management tools in most web browsers do support
renaming of bookmark names for easy recall. 

New toolchain currently in testing for subsequent releases of Red Hat Enterprise
Linux documentation may provide some improvements to HTML transformations,
including better titlepage <title> naming conventions.

Thanks again for your report.

Note You need to log in before you can comment on or make changes to this bug.