Bug 1024410 - CDI Cache interceptor tests are failing while running in EAP container
CDI Cache interceptor tests are failing while running in EAP container
Status: CLOSED NOTABUG
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER5
: 6.2.0
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks: 1017190
  Show dependency treegraph
 
Reported: 2013-10-29 11:36 EDT by Anna Manukyan
Modified: 2013-12-09 05:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 05:55:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ISPN-3316 Major Resolved CDI Cache interceptor tests are failing while running in EAP container 2013-12-17 02:04:10 EST

  None (edit)
Description Anna Manukyan 2013-10-29 11:36:34 EDT
Please find the detailed bug description here:

https://issues.jboss.org/browse/ISPN-3316
Comment 2 JBoss JIRA Server 2013-11-20 07:27:51 EST
Galder Zamarreño <galder.zamarreno@redhat.com> made a comment on jira ISPN-3316

@Anna, @Tristan, this went under the radar somehow. We discovered the same thing via a different path: quickstarts, in ISPN-3735.

@Anna, I'm currently working on a fix for this. Could you port over the tests you created in jdg-funbtional-tests to Infinispan Server?
Comment 3 JBoss JIRA Server 2013-11-20 09:30:25 EST
Galder Zamarreño <galder.zamarreno@redhat.com> made a comment on jira ISPN-3316

The problem, as mentioned in ISPN-3735 is that t injected cache resolver is not being used as alternative implementation for the cache resolver. This is because in CDI 1.0, alternatives can only be applied for injections in application, and not in libraries used by the application. Instead, I've created a paralell set of InjectCache*Interceptor classes for when InjectedCacheResolver is needed. I've tested the CDI quickstart with EAP 7.2 and it works fine.
Comment 4 JBoss JIRA Server 2013-11-20 11:36:27 EST
Galder Zamarreño <galder.zamarreno@redhat.com> made a comment on jira ISPN-3316

We're adding Wildfly CDI/JCache integration tests with this.
Comment 5 Vojtech Juranek 2013-12-09 05:55:35 EST
Interceptors were moved into JCache, thus tests require JCache (or some other implementation of JSR107) which is not part of product, so closing.

Note You need to log in before you can comment on or make changes to this bug.