Bug 1024430 - glance: taking an instance snapshot from instance booted from volume creates an unusable empty image
glance: taking an instance snapshot from instance booted from volume creates ...
Status: CLOSED DUPLICATE of bug 1026325
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
4.0
x86_64 Linux
unspecified Severity high
: ---
: 4.0
Assigned To: RHOS Maint
Ami Jeain
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 12:09 EDT by Dafna Ron
Modified: 2016-04-26 22:41 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 04:33:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (1.15 MB, application/x-gzip)
2013-10-29 12:09 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1245940 None None None Never

  None (edit)
Description Dafna Ron 2013-10-29 12:09:55 EDT
Created attachment 817132 [details]
logs

Description of problem:

I booted an instance from a volume and took an instance snapshot. 
we create an empty image which we cannot boot from 

Version-Release number of selected component (if applicable):

openstack-nova-compute-2013.2-4.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. boot an instance from volume 
2. take a snapshot of the instance from horizon
3. 

Actual results:

an empty unusable image is created 

Expected results:

we should not create an image 

Additional info: logs 

[root@cougar06 ~(keystone_admin)]# glance image-list 
+--------------------------------------+-------+-------------+------------------+-----------+--------+
| ID                                   | Name  | Disk Format | Container Format | Size      | Status |
+--------------------------------------+-------+-------------+------------------+-----------+--------+
| 8911ad09-bb7c-4461-886e-79b1088374cc | bla   |             |                  |           | active |
| d601cc8e-72b8-4137-baa8-e213c32c41ec | boo   |             |                  |           | active |
| 48bf2581-1df3-4c2a-ac34-11ec7b4aab20 | boo1  |             |                  |           | active |
| 365ad861-eb57-4488-86b8-daf5bd2af126 | boo2  |             |                  |           | active |
| 597066b9-bee9-4ca2-a29e-57f257a13b7f | image | qcow2       | bare             | 699592704 | active |


[root@cougar06 ~(keystone_admin)]# nova boot test1 --flavor 2 --image 8911ad09-bb7c-4461-886e-79b1088374cc
ERROR: Block Device Mapping is Invalid: Boot sequence for the instance and image/block device mapping combination is not valid. (HTTP 400) (Request-ID: req-60c8b66f-395b-471e-b4e2-5ea71e92ecfd)
Comment 1 Flavio Percoco 2013-11-11 09:03:15 EST
At first glance, this seems to be a nova bug since it's responsible for creating images and then `uploading` them to `glance-api`. In this whole process, glance does not modifies the image at all.

What makes you think this is a Glance bug? Any detail that I could be missing?
Comment 2 Dafna Ron 2013-11-15 03:34:08 EST
I opened on glance because I thought that the image would be created with glance and not nova (nova will call glance). but if not, please change component to nova :)
Comment 3 Xavier Queralt 2013-11-20 04:33:48 EST
Hey, I couldn't locate this bug in nova component and took the liberty of creating it. I didn't know it was already filled against glance ;)

Closing as a duplicate because the other one contains more information.

*** This bug has been marked as a duplicate of bug 1026325 ***

Note You need to log in before you can comment on or make changes to this bug.