Bug 1024431 - SELinux is preventing /usr/libexec/postfix/local from 'create' accesses on the directory Maildir.
SELinux is preventing /usr/libexec/postfix/local from 'create' accesses on th...
Status: CLOSED DUPLICATE of bug 1024394
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:728585dc3e4a9133cb0e7dd9416...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 12:12 EDT by Jeff MacDonald
Modified: 2013-10-29 12:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-29 12:50:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff MacDonald 2013-10-29 12:12:38 EDT
Description of problem:
SELinux is preventing /usr/libexec/postfix/local from 'create' accesses on the directory Maildir.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that local should be allowed create access on the Maildir directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep local /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:postfix_local_t:s0
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                Maildir [ dir ]
Source                        local
Source Path                   /usr/libexec/postfix/local
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           postfix-2.9.7-1.fc18.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-106.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.4-101.fc18.i686 #1 SMP Thu
                              Oct 10 14:33:33 UTC 2013 i686 i686
Alert Count                   1
First Seen                    2013-10-29 12:11:04 EDT
Last Seen                     2013-10-29 12:11:04 EDT
Local ID                      c5da5776-c281-4813-aa0a-e38a4dec9b91

Raw Audit Messages
type=AVC msg=audit(1383063064.468:49730): avc:  denied  { create } for  pid=32431 comm="local" name="Maildir" scontext=system_u:system_r:postfix_local_t:s0 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir


type=SYSCALL msg=audit(1383063064.468:49730): arch=i386 syscall=mkdir success=no exit=EACCES a0=b7842448 a1=1c0 a2=b77cba80 a3=b7842455 items=0 ppid=1466 pid=32431 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=local exe=/usr/libexec/postfix/local subj=system_u:system_r:postfix_local_t:s0 key=(null)

Hash: local,postfix_local_t,admin_home_t,dir,create

audit2allow

#============= postfix_local_t ==============
allow postfix_local_t admin_home_t:dir create;

audit2allow -R
require {
	type admin_home_t;
	type postfix_local_t;
	class dir create;
}

#============= postfix_local_t ==============
allow postfix_local_t admin_home_t:dir create;


Additional info:
reporter:       libreport-2.1.7
hashmarkername: setroubleshoot
kernel:         3.11.4-101.fc18.i686
type:           libreport
Comment 1 Daniel Walsh 2013-10-29 12:50:18 EDT

*** This bug has been marked as a duplicate of bug 1024394 ***

Note You need to log in before you can comment on or make changes to this bug.