Bug 102445 - sysstat's sar reports wrong values in case of reboot
sysstat's sar reports wrong values in case of reboot
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: sysstat (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Nils Philippsen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-15 03:35 EDT by Oliver Paukstadt
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-27 07:25:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Paukstadt 2003-08-15 03:35:44 EDT
Rebooting a box causes sysstat sar to report wrong data about the moment of reboot.
This is because RedHat linux does not write the Linux-Reboot record (dummy
record) to the sysstat statistics file. This causes wrong values if the data is
evaluated later because most values decrease in case of reboot.

sadc.c source says about the problem:
/*
 ***************************************************************************
 * sadc called with interval and count parameters not set:
 * write a dummy record notifying a system restart.
 * This should typically be called this way at boot time,
 * before the cron daemon is started to avoid conflict with sa1/sa2 scripts.
 ***************************************************************************
 */

To fix, add something like

[ -e /usr/lib/sa/sadc -a -x /usr/lib/sa/sadc ] && /usr/lib/sa/sadc

to rc.sysinit after it is clear /var is mounted (at least when the other
activities on /var start).
Comment 1 Greg Edwards 2003-11-17 12:41:35 EST
This is because the rpm does not contain the /etc/init.d/sysstat
script (sysstat.sh in the tarball).  It needs to be patched to play
nice with chkconfig.  Other than that, just a few lines in the spec
file will fix this.
Comment 2 Nils Philippsen 2004-01-13 11:20:20 EST
I consider this for future product versions.
Comment 3 Nils Philippsen 2004-01-27 07:25:09 EST
fixed in 5.0.0-0.6

Note You need to log in before you can comment on or make changes to this bug.