Bug 1024476 - Spurious wrong-script-interpreter on .in files
Spurious wrong-script-interpreter on .in files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 14:04 EDT by Orion Poplawski
Modified: 2013-10-30 09:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 03:57:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2013-10-29 14:04:49 EDT
Description of problem:

plplot-tk.x86_64: E: wrong-script-interpreter /usr/share/plplot5.9.10/examples/tk/tk01.in @xtk01_LOCATION@

# ls -l /usr/share/plplot5.9.10/examples/tk/tk01.in
-rw-r--r--. 1 root root 3707 Mar  2  2010 /usr/share/plplot5.9.10/examples/tk/tk01.in

# head -1 /usr/share/plplot5.9.10/examples/tk/tk01.in
#!@xtk01_LOCATION@ -f

This file is:
- Not executable
- Marked as %doc
- Is a .in file

Version-Release number of selected component (if applicable):
rpmlint-1.5-4.fc21.noarch
Comment 1 Ville Skyttä 2013-10-30 03:57:23 EDT
Why are you shipping the *.in files in the first place, given that you're also shipping the scripts generated from those which have the interpreter replaced? Not a bug as far as I'm concerned -- rpmlint successfully flagged a packaging issue.

$ for f in usr/share/plplot5.9.10/examples/tk/*.in ; do echo ${f%.in} ; echo $f ; done | xargs head -n 1
==> usr/share/plplot5.9.10/examples/tk/plgrid <==
#!/bin/sh

==> usr/share/plplot5.9.10/examples/tk/plgrid.in <==
#!/bin/sh

==> usr/share/plplot5.9.10/examples/tk/standard_examples <==
#!/usr/bin/bash

==> usr/share/plplot5.9.10/examples/tk/standard_examples.in <==
#!@SH_EXECUTABLE@

==> usr/share/plplot5.9.10/examples/tk/tk01 <==
#!/usr/share/plplot5.9.10/examples/tk/xtk01 -f

==> usr/share/plplot5.9.10/examples/tk/tk01.in <==
#!@xtk01_LOCATION@ -f

==> usr/share/plplot5.9.10/examples/tk/tk02 <==
#!/usr/share/plplot5.9.10/examples/tk/xtk02 -f

==> usr/share/plplot5.9.10/examples/tk/tk02.in <==
#!@xtk02_LOCATION@ -f

==> usr/share/plplot5.9.10/examples/tk/tk03 <==
#!/bin/sh

==> usr/share/plplot5.9.10/examples/tk/tk03.in <==
#!/bin/sh

==> usr/share/plplot5.9.10/examples/tk/tk04 <==
#!/usr/share/plplot5.9.10/examples/tk/xtk04 -f

==> usr/share/plplot5.9.10/examples/tk/tk04.in <==
#!@xtk04_LOCATION@ -f
Comment 2 Orion Poplawski 2013-10-30 09:46:10 EDT
Users are able to rebuild the examples as desired.

Note You need to log in before you can comment on or make changes to this bug.