Bug 1024490 - [RFE] document what is/what's not audited/logged for users added prior to Satellite upgrade for "spacewalk-report audit-users" (sat 5.6 feature) [NEEDINFO]
[RFE] document what is/what's not audited/logged for users added prior to Sat...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs User Guide (Show other bugs)
560
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Macpherson
Dan Macpherson
: FutureFeature
Depends On:
Blocks: sat-docs
  Show dependency treegraph
 
Reported: 2013-10-29 14:55 EDT by hmiles
Modified: 2015-10-05 22:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 22:27:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dmacpher: needinfo? (hmiles)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 519943 None None None Never

  None (edit)
Description hmiles 2013-10-29 14:55:32 EDT
Description of problem:

No mention of users added prior to upgrade not being included in "spacewalk-report audit-users"

In our reference guide for Satellite 5.6 : 

https://access.redhat.com/site/documentation/en-US/Red_Hat_Satellite/5.6/html-single/Reference_Guide/index.html#idp576480

Table 5.2. spacewalk-report Reports
Report 	              Invoked as   Description 
Users in the system   users 	   Lists all users registered to the Satellite 

This holds true for fresh Satellite 5.6 installations but not on upgrades. 

Because there was no reporting on this prior to 5.6 any users added prior to the upgrade will not be generated in this report.
Comment 3 Tomas Lestach 2013-10-31 06:27:05 EDT
The logging feature is on by default for fresh 5.6 installations.
For upgrading, the audit logging feature will be turned on at the time of upgrade and *since then* the all the events get audited. That means users created before the upgrade get logged from this point as well (their creation isn't logged, all the further events will be logged).
Comment 8 Dan Macpherson 2015-09-15 22:27:19 EDT
This fix appears to be implemented live on the portal:

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/5.7/html/User_Guide/chap-Generating_Red_Hat_Satellite_Reports.html

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/5.7/html/User_Guide/chap-Troubleshooting.html#idp13840856

Closing this bug and if further changes are required, please feel free to reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.