Bug 1024501 - TCP sockets used for initial connection stay in CLOSE_WAIT forever after migration(s)
TCP sockets used for initial connection stay in CLOSE_WAIT forever after migr...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
: 952375 (view as bug list)
Depends On:
Blocks: 952375
  Show dependency treegraph
 
Reported: 2013-10-29 15:37 EDT by David Jaša
Modified: 2014-10-14 02:46 EDT (History)
7 users (show)

See Also:
Fixed In Version: spice-gtk-0.22-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 02:46:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-10-29 15:37:33 EDT
Description of problem:
TCP sockets used for initial connection stay in CLOSE_WAIT forever after migration(s). Sockets created during migration are destroyed properly - IOW after increasing number of migrations, you can see set of ports used at initial connection in CLOSED_WAIT state all the time + set of actually active ports

Version-Release number of selected component (if applicable):
spice-gtk-0.20-11.el6.i686

How reproducible:
always

Steps to Reproduce:
1. connect to a VM, look at TCP connection of {virt,remote}-viewer using netstat
2. migrate the VM, look at TCP connections
3. migrate the VM again, look at TCP connections
4. ...

Actual results:
connections that are ESTABLISHED after 1. remain in CLOSED_WAIT in further iterations

Expected results:
only ESTABLISHED connections exist

Additional info:
proxy has no effect on this behaviour
Comment 1 RHEL Product and Program Management 2013-11-01 15:57:54 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Marc-Andre Lureau 2014-02-18 14:44:29 EST
*** Bug 952375 has been marked as a duplicate of this bug. ***
Comment 7 errata-xmlrpc 2014-10-14 02:46:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1487.html

Note You need to log in before you can comment on or make changes to this bug.