Bug 1024505 - fs.sh: Fix "support" of tmpfs
fs.sh: Fix "support" of tmpfs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents (Show other bugs)
6.5
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Oyvind Albrigtsen
cluster-qe@redhat.com
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 15:53 EDT by Jaroslav Kortus
Modified: 2016-05-10 15:12 EDT (History)
6 users (show)

See Also:
Fixed In Version: resource-agents-3.9.5-28.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 15:12:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Working patch (1.16 KB, patch)
2015-11-02 05:39 EST, Oyvind Albrigtsen
no flags Details | Diff
Updated working patch (1.21 KB, patch)
2015-11-09 07:44 EST, Oyvind Albrigtsen
no flags Details | Diff

  None (edit)
Description Jaroslav Kortus 2013-10-29 15:53:30 EDT
Description of problem:
Currently tmpfs is recognized as a supported filesystem of fs.sh resource.
This filesystem cannot work in current implementation ("none" device is not supported and later it requires fsck).

As probably no one has ever run it, we could drop it from the agent.

Version-Release number of selected component (if applicable):
resource-agents-3.9.2-40.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. add <fs device="/dev/loop0" fstype="tmpfs" mountpoint="/tmp/fstest" name="filesystem"/> to your cluster service
2.
3.

Actual results:
tmpfs cannot be mounted via rgmanager

Expected results:
message that tmpfs is not supported

Additional info:
Comment 5 Oyvind Albrigtsen 2015-11-02 05:39 EST
Created attachment 1088533 [details]
Working patch
Comment 6 Oyvind Albrigtsen 2015-11-02 05:40:31 EST
Tested patch. Had to change the return code from OCF_ERR_ARGS as utils/fs-lib.sh thought that means success.
Comment 7 Oyvind Albrigtsen 2015-11-09 07:44 EST
Created attachment 1091728 [details]
Updated working patch

Improved the patch and tested that it's working without any issues.
Comment 8 Oyvind Albrigtsen 2015-12-21 07:26:05 EST
Before:
- Error about none-device not being supported, or error when running fsck if device is set to e.g. /dev/loop0.

After:
- Message that tmpfs is not supported.
Comment 9 Oyvind Albrigtsen 2015-12-24 08:09:41 EST
Setup:
Add the following service to /etc/cluster/cluster.conf:
          <service autostart="0" domain="fodom" name="tmpfs">
               <fs device="/dev/loop0" fstype="tmpfs" mountpoint="/tmp/fstest" name="filesystem"/>
          </service>


Before:
# rpm -q resource-agents
resource-agents-3.9.5-24.el6_7.1.x86_64
# clusvcadm -e tmpfs
# tail -f /var/log/cluster/rgmanager.log
Dec 24 14:05:57 rgmanager Starting disabled service service:tmpfs
Dec 24 14:05:57 rgmanager [fs] start_filesystem: Creating mount point /tmp/fstest for device /dev/loop0
Dec 24 14:05:57 rgmanager [fs] Unknown file system type 'tmpfs' for device /dev/loop0.  Assuming fsck is required.
Dec 24 14:05:57 rgmanager [fs] Running fsck on /dev/loop0
Dec 24 14:05:57 rgmanager [fs] 'fsck -p /dev/loop0' failed, error=8; check /var/log/cluster/loop0.fsck.log for errors
Dec 24 14:05:57 rgmanager [fs] Invalidating buffers for /dev/loop0


After:
# rpm -q resource-agents
resource-agents-3.9.5-28.el6.x86_64
# clusvcadm -e tmpfs
# tail -f /var/log/cluster/rgmanager.log
Dec 24 14:06:57 rgmanager Starting disabled service service:tmpfs
Dec 24 14:06:57 rgmanager [fs] File system type tmpfs not supported
Comment 13 errata-xmlrpc 2016-05-10 15:12:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0735.html

Note You need to log in before you can comment on or make changes to this bug.