Bug 102456 - prelink-0.3.0-3: tons of errors from daily prelink job
prelink-0.3.0-3: tons of errors from daily prelink job
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: prelink (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-15 09:04 EDT by Jonathan Kamens
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version: prelink-0.3.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-08 05:32:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2003-08-15 09:04:24 EDT
A sample of them:

/etc/cron.daily/prelink:

/usr/sbin/prelink: /usr/bin/swais: Could not parse `/usr/bin/swais: error while 
loading shared libraries: libncurses.so.4: cannot open shared object file: No 
such file or directory'
/usr/sbin/prelink: /usr/bin/vmnet-natd: Could not parse `Incorrectly built 
binary which accesses errno or h_errno directly. Needs to be fixed.'
/usr/sbin/prelink: /usr/bin/xspread: Could not parse `Incorrectly built binary 
which accesses errno or h_errno directly. Needs to be fixed.'
/usr/sbin/prelink: /usr/bin/vmware-wizard: Could not parse `Incorrectly built 
binary which accesses errno or h_errno directly. Needs to be fixed.'
/usr/sbin/prelink: /usr/X11R6/bin/xtrojka: Could not parse `Incorrectly built 
binary which accesses errno or h_errno directly. Needs to be fixed.'
/usr/sbin/prelink: /usr/lib/openoffice/program/pkgchk.bin: Could not parse 
`/usr/lib/openoffice/program/pkgchk.bin: error while loading shared libraries: 
libsal.so.3: cannot open shared object file: No such file or directory'
/usr/sbin/prelink: /usr/lib/mozilla-1.4/mozilla-bin: Could not parse 
`/usr/lib/mozilla-1.4/mozilla-bin: error while loading shared libraries: 
libmozjs.so: cannot open shared object file: No such file or directory'
/usr/sbin/prelink: /usr/lib/mozilla-1.4/regchrome: Could not parse 
`/usr/lib/mozilla-1.4/regchrome: error while loading shared libraries: 
libxpcom.so: cannot open shared object file: No such file or directory'
/usr/sbin/prelink: /usr/lib/mozilla-
1.2.1/plugins/java2/bin/i386/green_threads/javac: Could not parse 
`/usr/lib/mozilla-1.2.1/plugins/java2/bin/i386/green_threads/javac: error while 
loading shared libraries: libhpi.so: cannot open shared object file: No such 
file or directory'
/usr/sbin/prelink: /usr/lib/mozilla-
1.2.1/plugins/java2/bin/i386/green_threads/javah: Could not parse 
`/usr/lib/mozilla-1.2.1/plugins/java2/bin/i386/green_threads/javah: error while 
loading shared libraries: libhpi.so: cannot open shared object file: No such 
file or directory'
Comment 1 Jakub Jelinek 2003-08-15 13:35:17 EDT
This is nothing fatal, prelink simply reporting why it couldn't prelink
certain programs.
You have some borken software installed (some vmware utilities from what I
can see), dunno if you can run swais at all if libncurses.so.4 is missing.
Then, openoffice/mozilla errors are because they use LD_LIBRARY_PATH
to run some programs. prelink doesn't know what LD_LIBRARY_PATH it should use,
so cannot prelink them. I've fixed most of the openoffice binaries last year,
so that they use DT_RPATH, but missed one. You can file a bug against openoffice
and/or mozilla if you want.
JDK apparently has similar problem.
The LD_LIBRARY_PATH issue can be solved by adding --ld-library-path /path1:/path2
to prelink arguments if you want (e.g. in /etc/sysconfig/prelink).
I don't see any problems with prelink itself in your log though.
Comment 2 Jonathan Kamens 2003-08-15 14:08:43 EDT
I must disagree with your claim that there is no prelink bug here.  The 
problems you described in such detail are common and are likely to pop up again 
and again forever.  Most of the software generating these errors is from 
standard Red Hat RPMs, and prelink simply shouldn't be sending E-mail to the 
admin every single night bitching about problems in standard software.

IMHO, the nightly automatic prelink should simply discard these errors.  You 
should add a command-line option to prelink telling it to be quiet about errors 
of this sort, if there isn't already such an option, and use that option in the 
daily automatic invocation of prelink.
Comment 3 Jakub Jelinek 2003-08-15 15:20:14 EDT
You haven't mentioned about getting this via mail.
That was certainly not intended, I just forgot to add 2>&1 in a two places.
Building prelink-0.3.0-4.

Note You need to log in before you can comment on or make changes to this bug.