Bug 1024581 - keystone missing tab completion
keystone missing tab completion
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: python-keystoneclient (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Ruzicka
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 21:53 EDT by Mohammed Arafa
Modified: 2016-04-26 11:17 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-keystoneclient-0.4.1-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:05:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Arafa 2013-10-29 21:53:23 EDT
Description of problem:
in /etc/profile.d i found the tab completion files for neutron nova and cinder. but there is no tab completion file for keystone

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Alan Pevec 2013-10-31 15:06:31 EDT
python-keystoneclient includes completion but under /etc/bash_completion.d/ and you need to have bash-completion RPM installed to get that sourced by default.
Putting completion files under /etc/profile.d/ in other packages is to avoid dependency on bash-completion which isn't in RHEL baseOS, it's an EPEL package.

Jakub, please make all *client consistent in el6 RDO in that regard.
Comment 3 Mohammed Arafa 2013-10-31 21:13:05 EDT
@alan
you mean remove the dependency on bash-completion by putting them in /etc/profile.d
Comment 4 Jakub Ruzicka 2013-11-07 08:45:30 EST
Actually, moving them to /etc/profile.d is bad and evil, because it's bash specific code but /etc/profile.d is share amongst the shell so for example when using zsh, you get ugly warning on shell start.

Since there is bash-completion in EPEL, I'll make client packages depend on and use that in RDO.
Comment 5 Jakub Ruzicka 2014-01-03 15:09:55 EST
I moved the completion to /etc/profile.d for compatibility with other clients. 

I'll use bash-completion in 5.0+ in the future if possible.

Note You need to log in before you can comment on or make changes to this bug.