Bug 1024633 - Error: requested datatype primary not available
Error: requested datatype primary not available
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum (Show other bugs)
6.4
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Jeff Sheltren
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 02:44 EDT by Mike Landis
Modified: 2014-03-21 11:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-21 11:40:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Landis 2013-10-30 02:44:25 EDT
Description of problem:
Every time I run yum, it emits the following message:
"Error: requested datatype primary not available"
after it successfully updates it's database for all repositories described in yum.repos.d

Version-Release number of selected component (if applicable):
yum-3.2.29-40.el6.centos.noarch

How reproducible:
EVERY time.

Steps to Reproduce:
1. yum update <anything, including nothing>
2.
3.

Actual results:
no modules updated

Expected results:
modules updated

Additional info:
"yum clean all" doesn't change a thing
Comment 1 Mike Landis 2013-10-30 02:48:35 EDT
FYI, this version of yum came bundled with Centos 6.4 (which I recently installed fresh).
Comment 3 Valentina Mukhamedzhanova 2014-03-21 11:40:37 EDT
The problem is not in yum. My advice would be to try to find out which repo is causing the problem. Probably renaming /var/cache/yum and running 'yum update' would help.

Note You need to log in before you can comment on or make changes to this bug.