Bug 1024649 - [RHSC] In the bricks sub-tab for a server, show the bricks in sorted order
[RHSC] In the bricks sub-tab for a server, show the bricks in sorted order
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: anmol babu
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 03:19 EDT by Shruti Sampat
Modified: 2015-05-13 12:26 EDT (History)
9 users (show)

See Also:
Fixed In Version: cb7
Doc Type: Bug Fix
Doc Text:
Previously, the bricks were not displayed in the sorted order in the Bricks sub-tab of the Hosts tab. Now, the bricks are sorted and displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:57:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (150.26 KB, image/png)
2013-10-30 03:19 EDT, Shruti Sampat
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20781 None None None Never
Red Hat Product Errata RHEA-2014:0208 normal SHIPPED_LIVE Red Hat Storage 2.1 enhancement and bug fix update #2 2014-02-25 07:20:30 EST

  None (edit)
Description Shruti Sampat 2013-10-30 03:19:13 EDT
Created attachment 817311 [details]
screenshot

Description of problem:
-----------------------
In the bricks sub-tab for a server, the bricks do not appear in sorted order. See attached screenshot.

The bricks should be grouped based on volume names, and the volume names need to be in sorted order.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.2-0.21.beta1.el6_4 

How reproducible:
Always

Steps to Reproduce:
1. Add a couple of nodes to a cluster and create some volumes with bricks on both servers.
2. Select one of the nodes from the Hosts tab, and click on the bricks sub-tab.

Actual results:
Bricks are not in sorted order.

Expected results:
Bricks should be sorted as mentioned above.

Additional info:
Comment 2 Shruti Sampat 2013-11-13 02:36:54 EST
Verified as fixed in Red Hat Storage Console Version: 2.1.2-0.23.master.el6_5. Bricks are listed, as groups, sorted in order of volume names, and for a particular volume, the bricks are shown in order of addition to the volume.
Comment 3 Shalaka 2014-01-06 06:10:26 EST
Please review the edited DocText.
Comment 5 errata-xmlrpc 2014-02-25 02:57:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.