Bug 1024650 - CVE-2013-4479 rubygem-sup: command injection flaw in content type handling [fedora-all]
CVE-2013-4479 rubygem-sup: command injection flaw in content type handling [f...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: rubygem-sup (Show other bugs)
21
All Linux
high Severity high
: ---
: ---
Assigned To: Praveen Kumar
Fedora Extras Quality Assurance
fst_ping=3,fst_owner=pjp
: Reopened, Security, SecurityTracking
Depends On: 1224028
Blocks: CVE-2013-4479
  Show dependency treegraph
 
Reported: 2013-10-30 03:19 EDT by Murray McAllister
Modified: 2015-12-02 11:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-01 22:01:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
shreyankg: needinfo+
shreyankg: needinfo+
shreyankg: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Murray McAllister 2013-10-30 03:19:27 EDT
This is an automatically created tracking bug!  It was created to ensure
that one or more security vulnerabilities are fixed in affected versions
of Fedora.

For comments that are specific to the vulnerability please use bugs filed
against the "Security Response" product referenced in the "Blocks" field.

For more information see:
http://fedoraproject.org/wiki/Security/TrackingBugs

When creating a Bodhi update request, please use the bodhi submission link
noted in the next comment(s).  This will include the bug IDs of this
tracking bug as well as the relevant top-level CVE bugs.

Please also mention the CVE IDs being fixed in the RPM changelog and the
Bodhi notes field when available.

Please note: this issue affects multiple supported versions of Fedora.
Only one tracking bug has been filed; please ensure that it is only closed
when all affected versions are fixed.

[bug automatically created by: add-tracking-bugs]
Comment 1 Murray McAllister 2013-10-30 03:19:37 EDT
Please use the following update submission link to create the Bodhi
request for this issue as it contains the top-level parent bug(s) as well
as this tracking bug.  This will ensure that all associated bugs get
updated when new packages are pushed to stable.

Please also ensure that the "Close bugs when update is stable" option
remains checked.

Bodhi update submission link:
https://admin.fedoraproject.org/updates/new/?type_=security&bugs=1024647,1024650
Comment 2 pjp 2014-12-03 13:24:35 EST
Hello shreyankg,

Could you please fix this soon?
Comment 4 Fedora End Of Life 2015-01-09 15:24:24 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2015-02-17 13:57:27 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 6 Eric Christensen 2015-04-06 14:58:23 EDT
Can you please push a fix for this package?
Comment 7 Eric Christensen 2015-04-23 09:14:52 EDT
Can an update be pushed for this package?

If I don't receive a response by Monday I'll start a non-responsive maintainer process for this package.
Comment 8 Shreyank Gupta 2015-04-24 05:44:45 EDT
(In reply to Eric Christensen from comment #7)
> Can an update be pushed for this package?
> 
> If I don't receive a response by Monday I'll start a non-responsive
> maintainer process for this package.

Please don't do that.
I have added Praveen Kumar, who has agreed to be the co-maintainer for sup.
Comment 9 Praveen Kumar 2015-04-27 09:08:35 EDT
(In reply to Shreyank Gupta from comment #8)
> (In reply to Eric Christensen from comment #7)
> > Can an update be pushed for this package?
> > 
> > If I don't receive a response by Monday I'll start a non-responsive
> > maintainer process for this package.
> 
> Please don't do that.
> I have added Praveen Kumar, who has agreed to be the co-maintainer for sup.

I will update this package soon with latest release.
Comment 10 Eric Christensen 2015-04-29 20:12:43 EDT
Awesome!
Comment 11 Fedora Update System 2015-05-01 03:43:40 EDT
rubygem-sup-0.21.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/rubygem-sup-0.21.0-1.fc22
Comment 12 Fedora Update System 2015-05-01 03:54:48 EDT
rubygem-sup-0.21.0-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/rubygem-sup-0.21.0-1.fc21
Comment 13 Fedora Update System 2015-05-02 14:04:54 EDT
Package rubygem-sup-0.21.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-sup-0.21.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7393/rubygem-sup-0.21.0-1.fc22
then log in and leave karma (feedback).
Comment 14 Eric Christensen 2015-05-21 09:46:23 EDT
Can this be pushed to stable now?  It seems to have been in testing for a while.  Also, can you push this fix to F20 as well?
Comment 15 Praveen Kumar 2015-05-22 00:11:01 EDT
(In reply to Eric Christensen from comment #14)
> Can this be pushed to stable now?  It seems to have been in testing for a
> while.  Also, can you push this fix to F20 as well?

There was a dependency update and I created a review request for it, once it's done will update it.
Comment 16 Fedora Update System 2015-09-03 01:38:26 EDT
ruby-ncurses-1.3.1-16.fc23 rubygem-sup-0.21.0-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14929
Comment 17 Fedora Update System 2015-09-04 03:34:12 EDT
ruby-ncurses-1.3.1-16.fc23, rubygem-sup-0.21.0-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update rubygem-sup ruby-ncurses'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14929
Comment 18 Fedora Update System 2015-09-07 12:36:03 EDT
ruby-ncurses-1.3.1-16.fc23, rubygem-sup-0.21.0-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora End Of Life 2015-11-04 11:01:44 EST
This message is a reminder that Fedora 21 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 21. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '21'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 21 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 20 Fedora End Of Life 2015-12-01 22:01:20 EST
Fedora 21 changed to end-of-life (EOL) status on 2015-12-01. Fedora 21 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.