Bug 1024666 - setfattr fails on directories when gfid-access xlator is loaded
setfattr fails on directories when gfid-access xlator is loaded
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 04:13 EDT by Pranith Kumar K
Modified: 2014-04-17 07:50 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:50:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2013-10-30 04:13:34 EDT
Description of problem:

gfid and inode are changed in ga_virtual_lookup_cbk. Because of these changes, operations on the file are failing with EINVAL because in setxattr call of gfid-access xlator it does not do the reverse equivalent of what happens in ga_virtual_lookup_cbk so dht-layout-set happens on one inode but setxattr is sent on some other inode.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. create a directory hierarchy with some depth.
2. for each gfid of these directories perform a setfattr
3. Some of the commands fail with Invalid Argument error.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2013-10-30 04:14:28 EDT
REVIEW: http://review.gluster.org/6194 (features/gfid-access: Handle inode remap when parent inode is NULL) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Anand Avati 2013-10-31 06:53:31 EDT
COMMIT: http://review.gluster.org/6194 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 301ecf4798ae5271b2155efee92e5d1ad734b05b
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Oct 30 11:57:01 2013 +0530

    features/gfid-access: Handle inode remap when parent inode is NULL
    
    Change-Id: Ic3f9d30d75df0bbbdf8fe28446fabe62d90fa854
    BUG: 1024666
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/6194
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Niels de Vos 2014-04-17 07:50:11 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.