Bug 1024700 - Feature state attribute of off in the virtual image descriptor doesn't work.
Feature state attribute of off in the virtual image descriptor doesn't work.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Giuseppe Scrivano
Virtualization Bugs
:
Depends On:
Blocks: 1024703
  Show dependency treegraph
 
Reported: 2013-10-30 05:38 EDT by hyao@redhat.com
Modified: 2014-10-14 02:24 EDT (History)
9 users (show)

See Also:
Fixed In Version: python-virtinst-0.600.0-20.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1024703 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:24:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hyao@redhat.com 2013-10-30 05:38:42 EDT
Description
Feature state attribute of off in the virtual image descriptor doesn't work.
Version:
# rpm -qa python-virtinst libvirt
python-virtinst-0.600.0-18.el6.noarch
libvirt-0.10.2-29.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.Prepare a virtual image XML descriptor file with feature acpi and apic state off included.
# cat image.xml
<image>
<name>do1</name>
<domain>
<boot type="hvm">
<guest>
<arch>x86_64</arch>
<feature>
    <acpi state="off"/>
    <apic state="off"/>
</feature>
</guest>
<os>
...
</image>

2. Create a virtual machine from image.xml
#virt-image  image.xml

3. Check the domain configuration file
# virsh dumpxml do1
<domain type='kvm' id='88'>
  <name>do1</name>
  <uuid>0fb9974d-05e4-a326-d5d4-be768e644278</uuid>
  <memory unit='KiB'>262144</memory>
  <currentMemory unit='KiB'>262144</currentMemory>
  <vcpu placement='static'>1</vcpu>
  <os>
    <type arch='x86_64' machine='rhel6.5.0'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
....


4. Check the feature description in manual.
#man 5 virt-image
...
           The features element indicates whether certain platform features should be on or off. Currently, the platform
           features are pae, acpi, and apic. They can be turned on or off by giving a state attribute of either "on" or "off".
           When a feature is mentioned in the features element, it defaults to "on".

5. Destroy and undefine the domain do1. Turn off the feature by  --noapic and --noacpi options.
# virt-image --noapic --noacpi image.xml
Creating guest do1...
Creating domain...                                       |    0 B     00:00    

# virsh dumpxml do1
<domain type='kvm' id='89'>
  <name>do1</name>
  <uuid>9e1b44a0-a97e-b395-eaf8-2662c474475f</uuid>
  <memory unit='KiB'>262144</memory>
  <currentMemory unit='KiB'>262144</currentMemory>
  <vcpu placement='static'>1</vcpu>
  <os>
    <type arch='x86_64' machine='rhel6.5.0'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <pae/>
  </features>


Actual results:
State attribute of off in the virtual image descriptor doesn't work for virt-image, and --noapic and --noacpi options work well.

Expected results:
According to the description in the manual 5, state attribute of off in the virtual image descriptor doesn't work for virt-image

Additional info:
Comment 2 Giuseppe Scrivano 2014-01-29 07:13:07 EST
it seems to me like a problem in the documentation.

Patch proposed upstream: https://www.redhat.com/archives/virt-tools-list/2014-January/msg00226.html
Comment 6 zhoujunqin 2014-05-06 05:08:20 EDT
Reproduce with package:
virt-manager-0.9.0-19.el6.x86_64
python-virtinst-0.600.0-18.el6.noarch

Verified with package:
python-virtinst-0.600.0-20.el6.noarch
virt-manager-0.9.0-20.el6.x86_64

steps:

# man 5 virt-image
...
           The features element indicates whether certain platform features should be on or off. Currently, the
           platform features are pae, acpi, and apic. Omitting a togglable feature tag turns it off.
...

Since this bug is a problem in the documentation and has been fixed in latest version,do not mention state="on|off" for features,marked as verified.
Comment 7 errata-xmlrpc 2014-10-14 02:24:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1444.html

Note You need to log in before you can comment on or make changes to this bug.