Bug 1024748 - Init script configtest function fails while using configfile (slapd.conf)
Init script configtest function fails while using configfile (slapd.conf)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openldap (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Synacek
David Spurek
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 07:04 EDT by Félix
Modified: 2015-03-02 00:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:58:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch: remove double quotes (528 bytes, patch)
2013-11-08 07:57 EST, Jan Synacek
no flags Details | Diff

  None (edit)
Description Félix 2013-10-30 07:04:58 EDT
Description of problem:
Init script runs a configtest before start. That configtest function tests db directories. The regular expression to get dbdirs checks for lines like:
directory       /var/lib/ldap/something

but correct syntax for slapd.conf is:
directory       "/var/lib/ldap/something"

so configtest checks if "/var/lib/ldap/something" (with quotes) is a directory, and of course it fails, so slapd doesn't start.


Version-Release number of selected component (if applicable):
openldap-servers-2.4.23-32.el6_4.1.x86_64


How reproducible:
always

Steps to Reproduce:
1. Install openldap-servers
2. Use a config file /etc/openldap/slapd.conf, not config dir.
3. Set a directory directive like:
directory       "/var/lib/ldap/something"
4. Try to start service.

Actual results:
No output. slapd doesn't start.

Expected results:
slapd starts.

Additional info:
slaptest returns "config file testing succeeded"
Comment 2 Jan Synacek 2013-11-08 07:57:09 EST
Created attachment 821604 [details]
patch: remove double quotes

Simply remove double quotes from the values.
Comment 7 errata-xmlrpc 2014-10-14 00:58:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1426.html

Note You need to log in before you can comment on or make changes to this bug.