This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1024753 - (CVE-2013-4473) CVE-2013-4473 poppler: stack-based buffer overflow in pdfseparate utility
CVE-2013-4473 poppler: stack-based buffer overflow in pdfseparate utility
Status: CLOSED NOTABUG
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20131026,repor...
: Security
Depends On: 1024765 1025160
Blocks: 1025135 1025136
  Show dependency treegraph
 
Reported: 2013-10-30 07:21 EDT by Ratul Gupta
Modified: 2016-03-04 06:36 EST (History)
4 users (show)

See Also:
Fixed In Version: poppler 0.24.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 02:44:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ratul Gupta 2013-10-30 07:21:49 EDT
Poppler is found to be affected by a stack based buffer overflow vulnerability in the pdfseparate utility. Successfully exploiting this issue could allow remote attackers to execute arbitrary code in the context of the affected application. Failed exploits may result in denial-of-service conditions. 

The issue is said to be fixed in poppler 0.24.2.

References:
http://seclists.org/oss-sec/2013/q4/181

Commit:
http://cgit.freedesktop.org/poppler/poppler/diff/utils/pdfseparate.cc?id=b8682d868ddf7f741e93b
Comment 1 Ratul Gupta 2013-10-30 07:41:47 EDT
Created poppler tracking bugs for this issue:

Affects: fedora-all [bug 1024765]
Comment 2 Huzaifa S. Sidhpurwala 2013-10-31 02:44:12 EDT
This flaw affects the pdfseparate utility shipped with poppler. This utility is not shipped with the version of poppler shipped with Red Hat Enterprise Linux 5 and 6.
Comment 3 Huzaifa S. Sidhpurwala 2013-10-31 02:44:55 EDT
Statement:

Not Vulnerable. This issue does not affect the version of poppler as shipped with Red Hat Enterprise Linux 5 and 6.
Comment 5 Fedora Update System 2013-11-10 21:24:51 EST
poppler-0.22.1-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-11-16 02:15:36 EST
poppler-0.20.2-17.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.