This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1024772 - rhc snapshot save app will ssh into the app instead of snapshot to a file when app is using kerberos authorization
rhc snapshot save app will ssh into the app instead of snapshot to a file whe...
Status: CLOSED DUPLICATE of bug 1024102
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 07:50 EDT by weiwei jiang
Modified: 2016-10-30 18:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 11:30:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
configure kerberos authorization (1.29 KB, application/x-shellscript)
2013-10-30 07:50 EDT, weiwei jiang
no flags Details

  None (edit)
Description weiwei jiang 2013-10-30 07:50:51 EDT
Created attachment 817443 [details]
configure kerberos authorization

Description of problem:
When add a krb5-principalsshkey to a app and active kerberos authorization, it can ssh into, but snapshot save will ssh into the app instead of snapshot to a file 

# rhc snapshot save app
Pulling down a snapshot to app.tar.gz...
bash: cannot set terminal process group (-1): Invalid argument
bash: no job control in this shell

    *********************************************************************

    You are accessing a service that is for use only by authorized users.  
    If you do not have authorization, discontinue use at once. 
    Any use of the services is subject to the applicable terms of the 
    agreement which can be found at: 
    https://www.openshift.com/legal

    *********************************************************************

    Welcome to OpenShift shell

    This shell will assist you in managing OpenShift applications.

    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!
    Shell access is quite powerful and it is possible for you to
    accidentally damage your application.  Proceed with care!
    If worse comes to worst, destroy your application with "rhc app delete"
    and recreate it
    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!

    Type "help" for more info.


WARNING: This ssh terminal was started without a tty.
          It is highly recommended to login with: ssh -t
[app-y.dev.rhcloud.com 5270cf47e97c04dfc1000008]\>

Version-Release number of selected component (if applicable):
devenv_3966
rhc-1.16.5

How reproducible:
always

Steps to Reproduce:
1.configure kerberos authorization with attachment script on instance
2.create an app
3.remove all other type sshkeys
4.add a krb5-principal type sshkey
5.change the selinux context
chcon -t krb5_home_t /var/lib/openshift/$gear_id/.k5login
6.initialize a ticket for the krb5-principal sshkey content
7.snapshot save the app

Actual results:
# rhc snapshot save app
Pulling down a snapshot to app.tar.gz...
bash: cannot set terminal process group (-1): Invalid argument
bash: no job control in this shell

    *********************************************************************

    You are accessing a service that is for use only by authorized users.  
    If you do not have authorization, discontinue use at once. 
    Any use of the services is subject to the applicable terms of the 
    agreement which can be found at: 
    https://www.openshift.com/legal

    *********************************************************************

    Welcome to OpenShift shell

    This shell will assist you in managing OpenShift applications.

    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!
    Shell access is quite powerful and it is possible for you to
    accidentally damage your application.  Proceed with care!
    If worse comes to worst, destroy your application with "rhc app delete"
    and recreate it
    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!

    Type "help" for more info.


WARNING: This ssh terminal was started without a tty.
          It is highly recommended to login with: ssh -t
[app-y.dev.rhcloud.com 5270cf47e97c04dfc1000008]\> 

Expected results:
It should display like the following:
# rhc snapshot save php
Pulling down a snapshot to php.tar.gz...
Creating and sending tar.gz
RESULT:
Success


Additional info:
Comment 1 Jordan Liggitt 2013-10-30 11:30:43 EDT
Same cause as BZ1024102, additional commands passed into ssh weren't handled correctly when using kerberos auth

*** This bug has been marked as a duplicate of bug 1024102 ***

Note You need to log in before you can comment on or make changes to this bug.