Bug 1024780 - puppet-ceilometer uses deprecated DEFAULT group for os_* credentials related config
puppet-ceilometer uses deprecated DEFAULT group for os_* credentials related ...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
4.0
Unspecified Unspecified
low Severity low
: z1
: 5.0 (RHEL 7)
Assigned To: Gaël Chamoulaud
Amit Ugol
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 08:15 EDT by Eoghan Glynn
Modified: 2016-04-26 17:11 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-2014.1-12.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-30 13:50:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eoghan Glynn 2013-10-30 08:15:43 EDT
Description of problem:

The puppet-ceilometer module places the os_* credentials related config options in the [DEFAULT] section instead of [service_credentials].

https://github.com/stackforge/puppet-ceilometer/blob/master/manifests/agent/auth.pp

The two sections are effectively equivalent for the purposes of the os_* config options (via the deprecated_group mechanism).

However all usages of DEFAULT/os_* should be changed to the corresponding service_credentials/os_* option, in order to be using the most up-to-date grouping (as referenced in the docco etc.)


Version-Release number of selected component (if applicable):

master


How reproducible:

100%


Steps to Reproduce:
1. sudo packstack
2. sudo openstack-config --get /etc/ceilometer/ceilometer.conf DEFAULT os_username


Actual results:
ceilometer


Expected results:
Parameter not found: os_username


Additional info:
Note this is purely cosmetic, the deprecated [DEFAULT] group will continue to work for these options.
Comment 2 Alvaro Lopez Ortega 2013-11-15 08:00:55 EST
ACK. Update is due here.
Comment 3 Alvaro Lopez Ortega 2013-11-15 08:02:10 EST
It works in Havana, so setting severity to low.
Comment 4 Gaël Chamoulaud 2014-07-25 11:22:07 EDT
The fix has already been merged upstream since havana [1] and this commit is part of openstack-puppet-module since may 19th, 2014 [2]. So If I am not making a mistake, it should be present in the opm packages from openstack-puppet-modules-2014.1-12 version.

[1] https://github.com/stackforge/puppet-ceilometer/commit/3e3c021a81b015323c2fe0243f138f90c2cd2eb7
[2] https://github.com/redhat-openstack/openstack-puppet-modules/commit/25a7ce4d0e4d8df1cb2233716924efd9d19a2a37
Comment 7 Amit Ugol 2014-09-14 04:09:24 EDT
Tested on RHEL 6.5 and 7.0 with puppet-modules version 2014.1-21.8
in 
/usr/share/openstack-puppet/modules/ceilometer/manifests/agent/auth.pp
all os_* creds are with the service_credentials/os_ option.
Installation was successful and the relevant services are up and running.
Comment 11 errata-xmlrpc 2014-09-30 13:50:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1324.html

Note You need to log in before you can comment on or make changes to this bug.