Bug 1024781 - qemu-system-x86_64: symbol lookup error: qemu-system-x86_64: undefined symbol: rbd_aio_flush
qemu-system-x86_64: symbol lookup error: qemu-system-x86_64: undefined symbol...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
: Reopened
Depends On: 995883
Blocks: TRACKER-bugs-affecting-libguestfs
  Show dependency treegraph
 
Reported: 2013-10-30 08:25 EDT by Karel Volný
Modified: 2013-12-30 20:54 EST (History)
15 users (show)

See Also:
Fixed In Version: qemu-1.4.2-15.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 995883
Environment:
Last Closed: 2013-12-30 20:54:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-10-30 08:25:06 EDT
I've just hit this on F19 ...

I got ceph-libs-0.56.4-1.fc19.x86_64 installed as a dependency while ceph-libs-0.67.3-2.fc19.x86_64 is available in updates (and it fixes the problem)

+++ This bug was initially created as a clone of Bug #995883 +++
Comment 1 Cole Robinson 2013-10-31 16:35:58 EDT
The F19 package should have the fix since September. How did you hit this?
Comment 2 Karel Volný 2013-11-28 13:35:45 EST
(In reply to Cole Robinson from comment #1)
> The F19 package should have the fix since September. How did you hit this?

well ... the missing part here, which I deemed unimportant at first, is that the affected package was qemu-img

I just googled the error message and thought it is the same problem, so I cloned; I've learned about the workaround of manually upgrading ceph-libs, so I hadn't chance to test anything else (and possibly get the needed update automatically) afterwards

so, the full story is that qemu-img depends on

librados.so.2()(64bit)
librbd.so.1()(64bit)

which is not enough (bug #995883 comment #8)

the fix for bug #995883 was done in qemu-common, so pulling in qemu-common means pulling in correct version of ceph-libs

but qemu-img does not depend on qemu-common ...
Comment 3 Cole Robinson 2013-12-02 14:23:13 EST
Thanks for following up, moving to POST since the solution is known here
Comment 4 Fedora Update System 2013-12-18 12:51:48 EST
qemu-1.4.2-15.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qemu-1.4.2-15.fc19
Comment 5 Fedora Update System 2013-12-19 20:52:38 EST
Package qemu-1.4.2-15.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.4.2-15.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23641/qemu-1.4.2-15.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-12-30 20:54:58 EST
qemu-1.4.2-15.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.