Bug 102483 - "Test in progress" can display wrong test
"Test in progress" can display wrong test
Status: CLOSED CURRENTRELEASE
Product: Red Hat Academy
Classification: Retired
Component: Web Application (Show other bugs)
9
All Linux
high Severity medium
: ---
: ---
Assigned To: Luke Meyer
Bowe Strickland
https://academy.redhat.com/student/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-15 16:10 EDT by Bowe Strickland
Modified: 2007-03-27 00:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-26 11:26:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bowe Strickland 2003-08-15 16:10:31 EDT
Description of problem:
If you return to the front page during, say, a lab test, it appropriatly
displays a test in progress.  Inappropriatley, if more than one test was
enabled, it shows the wrong one.


How reproducible:
twice for me...

Steps to Reproduce:
1. enable multiple tests
2. start any except (i suspect) the last one
3. return to home page... wrong test (last enabled, not necessarily one
currently being taken) is shown.

particularly vicious, because you can't get back to finish your test!
Comment 1 Luke Meyer 2003-08-19 11:59:50 EDT
the order is dependent on how a list comes out of the database, so this can be
somewhat elusive.  anyway, i'm on it.
Comment 2 Luke Meyer 2003-08-19 14:18:35 EDT
now on webtest.
Comment 3 Luke Meyer 2003-08-26 11:26:34 EDT
did the bugzilla DB revert?  I thought I'd marked all these live.  Anyway these
fixes should be live now.

Note You need to log in before you can comment on or make changes to this bug.