Bug 1024835 - Setting nsds5ReplicaEnabled attribute to Off is not working on i386
Setting nsds5ReplicaEnabled attribute to Off is not working on i386
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.5
i386 Linux
unspecified Severity high
: rc
: ---
Assigned To: Rich Megginson
Sankar Ramalingam
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 09:43 EDT by Sankar Ramalingam
Modified: 2013-12-18 14:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 14:28:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sankar Ramalingam 2013-10-30 09:43:35 EDT
Description of problem: Changing the attribute value "nsds5ReplicaEnabled" set to Off is not working. The replication still working even after setting the value to Off.

Version-Release number of selected component (if applicable): 389-ds-base-1.2.11.15-29


How reproducible: Consistent


Steps to Reproduce:
1. Install latest 389-ds-base on RHEL6.5 i386 machine and setup 2 way MMR.
2. Once the replication is in place, change the attribute value "nsds5replicaEnabled" to Off on M1.
3. Create few entries on M1 and check whether the entries synced to M2.

Actual results: Entries sync to M2


Expected results: Entries should be stopped from syncing to M2.


Additional info: Few lines of reports from acceptance execution...

----------------- Starting Test bug834074_04 -------------------------
====================================================================
Changing the value of nsds5ReplicaEnabled to OFF again in M1, Modify the entry in M1, and check it should not be modified in M2
Modify nsds5ReplicaEnabled's value to off on Master M1
modifying entry cn=M1_to_M2,cn=replica,cn="dc=example,dc=com",cn=mapping tree,cn=config

Modify test entry on M1
modifying entry uid=test_bug834074,dc=example,dc=com

check test entry should not be modified in M2
/usr/lib/mozldap/ldapsearch -1 -p 30102 -D cn=directory manager -w Secret123 -b dc=example,dc=com objectClass=* | grep -i mail:test_bug834074_2
mail: test_bug834074_2
ldapsearch on m2 passed, and test case failed as attribute nsds5ReplicaEnabled is OFF on M1
TestCase [bug834074_04] result-> [FAIL]



==================================================================
----------------- Starting Test bug834074_02 -------------------------
==================================================================
To verify nsds5ReplicaEnabled's function in Master-Master Replication when it is OFF - Adding data to M1
Modify nsds5ReplicaEnabled's value to off on Master M1
/usr/lib/mozldap/ldapmodify -h localhost -p 30100 -D cn=directory manager -w Secret123 -f /tet/tet/../data/DS/6.0/mmrepl/fourwaymmr//nsds5ReplicaEnabled_off
modifying entry cn=M1_to_M2,cn=replica,cn="dc=example,dc=com",cn=mapping tree,cn=config

Adding the test entry in M1
adding new entry uid=test_bug834074,dc=example,dc=com

check the replication should not be happened in M2
dn: uid=test_bug834074,dc=example,dc=com
ldapsearch on m2 passed, and test case failed as attribute nsds5ReplicaEnabled is OFF on M1
TestCase [bug834074_02] result-> [FAIL]
Comment 2 Rich Megginson 2013-10-30 10:45:18 EDT
Does it work on x86_64?
Comment 3 mreynolds 2013-10-31 11:11:39 EDT
I can not reproduce this on:

389-ds-base-1.2.11.15-29.el6.i686
389-ds-base-debuginfo-1.2.11.15-29.el6.i686
389-ds-base-devel-1.2.11.15-29.el6.i686
389-ds-base-libs-1.2.11.15-29.el6.i686

or 

389-ds-base-1.2.11.15
389-ds-base-1.2.11.24
389-ds-base-1.3.2

Maybe you need a "sleep 1" after setting the agreement to "off"?
Comment 4 RHEL Product and Program Management 2013-11-03 10:15:09 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Sankar Ramalingam 2013-11-12 06:08:30 EST
(In reply to mreynolds from comment #3)
> I can not reproduce this on:
> 
> 389-ds-base-1.2.11.15-29.el6.i686
> 389-ds-base-debuginfo-1.2.11.15-29.el6.i686
> 389-ds-base-devel-1.2.11.15-29.el6.i686
> 389-ds-base-libs-1.2.11.15-29.el6.i686
> 
> or 
> 
> 389-ds-base-1.2.11.15
> 389-ds-base-1.2.11.24
> 389-ds-base-1.3.2
> 
> Maybe you need a "sleep 1" after setting the agreement to "off"?

Added sleep 5 to verify this. The test execution still fails on 32 bit.

Few lines from the report...

Modify nsds5ReplicaEnabled's value to off on Master M1
/usr/lib/mozldap/ldapmodify -h localhost -p 30100 -D cn=directory manager -w Secret123 -f /tet/tet/../data/DS/6.0/mmrepl/fourwaymmr//nsds5ReplicaEnabled_off
modifying entry cn=M1_to_M2,cn=replica,cn="dc=example,dc=com",cn=mapping tree,cn=config

Adding sleep of 5 secs as per Mark's comment for bug #1024835 on i386 platform
Adding the test entry in M1
adding new entry uid=test_bug834074,dc=example,dc=com

check the replication should not be happened in M2
dn: uid=test_bug834074,dc=example,dc=com
ldapsearch on m2 passed, and test case failed as attribute nsds5ReplicaEnabled is OFF on M1
TestCase [bug834074_02] result-> [FAIL]
Comment 6 mreynolds 2013-11-12 10:05:03 EST
Sankar, what happens when you manually run the test?  

Also, is this test system still setup?  Can I log on to the system to poke around?
Comment 7 mreynolds 2013-12-18 14:28:52 EST
From an email with Sankar:

"I cloned another beaker job and this time the result shows 100% PASS. I am not going to spend much time on it since its not a consistent failure. So, closing the bug as "Not a Bug". "

Closing bug for Sankar...

Note You need to log in before you can comment on or make changes to this bug.