Bug 1024844 - systemtap-testsuite requires prelink
systemtap-testsuite requires prelink
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemtap (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Frank Ch. Eigler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 09:51 EDT by Bill Nottingham
Modified: 2014-03-16 23:34 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 14:50:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2013-10-30 09:51:59 EDT
Description of problem:

The references I can find are in:

/usr/share/systemtap/testsuite/systemtap.exelib/exelib.exp

Reading that, it says:

            # Only use prelink if it exists on this platform
            set prelink_bin "/usr/sbin/prelink"
            if {[file exists $prelink_bin]} {
                set libprelink_opts {no yes}
            } else {
                set libprelink_opts {no}
            }

If I'm reading it correctly, it appears like this doesn't need to be a hard dependency. Am I missing something?

Version-Release number of selected component (if applicable):

systemtap-testsuite-2.3-1.fc19, presumably later versions

How reproducible:

100%

Steps to Reproduce:
1. look for runtime or build dependencies on prelink

Actual results:

Found one!
Comment 1 Frank Ch. Eigler 2013-10-30 09:54:45 EDT
Bill, why do you think this is a problem?  As long as prelink is available
in the distro (even if non-default), the systemtap testsuite tries to assert
our continued compatibility with it.  Since systemtap-testuite isn't (and
shouldn't be) in the comps as a default part of the install, what's the problem
with it depending on another non-default part?
Comment 2 David Smith 2013-10-30 11:20:30 EDT
My understanding of this bug is that we need to remove the systemtap-testsuite rpm's requirement of prelink in the spec file.
Comment 3 Mark Wielaard 2013-10-30 11:42:27 EDT
(In reply to David Smith from comment #2)
> My understanding of this bug is that we need to remove the
> systemtap-testsuite rpm's requirement of prelink in the spec file.

No please. Why would we do that?
The testsuite depends on prelink to be able to test some issues.
Yes, it will also run if prelink isn't available, but that means not all tests are ran. I really do want our tests to run fully by default (using prelink in the testsuite makes sure we are testing certain ELF file manipulations that might happen - even without prelink installed - on the user machine).

BTW. The testsuite prelink Requires is already only for those arches that provide that package.
Comment 4 Bill Nottingham 2013-10-30 12:22:26 EDT
Requirement of prelink would lead to installation of prelink, which would lead to prelink being fully operational on the machine in question. (That is something that can be fixed in prelink, of course.)

I just wanted to clarify what the relationship dependency was, if the code itself implied it was optional.
Comment 5 Frank Ch. Eigler 2013-10-30 14:50:07 EDT
The systemtap-testsuite package is unlikely to be installed by casual users,
or ones who would be unable to clean up things like undesireable prelinkedness
afterwards.  IMHO this is not worth changing on the systemtap end until/unless
prelink is removed entirely (which would be a shame).

Note You need to log in before you can comment on or make changes to this bug.