This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1024848 - RFE -- Introduce a manual refresh for "Gluster Hooks"
RFE -- Introduce a manual refresh for "Gluster Hooks"
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc-sdk (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Shubhendu Tripathi
Mike McCune
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 09:55 EDT by Dustin Tsang
Modified: 2015-08-31 05:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 05:56:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dustin Tsang 2013-10-30 09:55:47 EDT
Description of problem:

Introduce a manual refresh for "Gluster Hooks". Currently the refresh interval is 2hrs and hence the user will have to wait till then to retrieve the a list of gluster hooks.

For the usability and testability sake of the api, adding a manual refresh call is essential since scripts that are trying to manipulate gluster hooks shouldn't be expected to run for more than a few seconds. 


Version-Release number of selected component (if applicable):

rhsc-cb5

How reproducible:
100%

Steps to Reproduce:
1. N/A
2.
3.

Actual results:
N/A


Expected results:
N/A


Additional info:
Comment 2 Dusmant 2013-11-05 22:20:24 EST
We should document this behaviour till this time lag is addressed.
Comment 5 Dusmant 2015-08-31 05:56:56 EDT
We are not planning to fix it. Hence closing this BZ. If you think, it's applicable for 3.x release and would have an impact on customer, pls. open up a new BZ with the appropriate version. Thanks, -Dusmant

Note You need to log in before you can comment on or make changes to this bug.