Bug 1024851 - Engine to pass UUID along with IP / FQDN to the VDSM layer for host remove
Engine to pass UUID along with IP / FQDN to the VDSM layer for host remove
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Timothy Asir
storage-qa-internal@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 10:03 EDT by Timothy Asir
Modified: 2015-12-28 01:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 01:37:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20731 None ABANDONED gluster: add gluster host uuid along with host name/ip for remove host Never

  None (edit)
Description Timothy Asir 2013-10-30 10:03:42 EDT
Description of problem:
when a (vdsm) node has more than one nic or 
     a node peer probed using name or 
     its peer probed using an alternate ip,
the remove host task sent from the engine failed with "peer host not found" error.

Version-Release number of selected component (if applicable):
cb5

How reproducible:


Steps to Reproduce:
1. Add nodes with more then 2 nics to the engine (rhsc)
2. Remove one node


Actual results:


Expected results:


Additional info:
This error occurs, whenever an engine sends a name or ip of a host to be removed to a node which doesn't aware of or doesn't have the host name or ip entry in its peer list (status). To avoid this, the engine can send gluster host uuid also along with host name to the vdsm and the vdsm can check the uuid and remove (detach) the appropriate host.
Comment 2 Timothy Asir 2013-10-31 00:57:16 EDT
patch send to upstream: http://gerrit.ovirt.org/#/c/20731/
Comment 3 Timothy Asir 2013-12-10 04:30:30 EST
This issue occurs due to wrong configuration.
Comment 4 Timothy Asir 2013-12-10 05:35:41 EST
Currently dns configuration is required for rhs. It will work
properly when we have fully qualified domain name for a host.
So that it can uniquely identify the server. This can also be
temporarily configured using host file in /etc/host.
Comment 5 Dusmant 2013-12-10 11:26:58 EST
Taking this bug out of Corbett list.
Comment 6 Kanagaraj 2014-05-22 00:04:12 EDT
Moving to ASSIGNED as the patch is abandoned in upstream.
Comment 8 Dusmant 2015-12-28 01:37:39 EST
RHSC 2.1 is EOLed and we don't have any plan to fix this issue.
If you think, this is an important bug to be addressed, pls. re-open it on the latest release. 
I will go ahead and "CLOSE" this bug for this release.

Note You need to log in before you can comment on or make changes to this bug.