Bug 1024895 - cz:75:19: illegal escape sequence in string literal
cz:75:19: illegal escape sequence in string literal
Status: CLOSED DUPLICATE of bug 1100231
Product: Fedora
Classification: Fedora
Component: xkeyboard-config (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 10:49 EDT by Jozef Mlich
Modified: 2015-08-02 19:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 06:52:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jozef Mlich 2013-10-30 10:49:38 EDT
Description of problem:
There is an illegal escape sequence in string literal in /usr/share/X11/xkb/symbols/cz 


Version-Release number of selected component (if applicable):
2.10.1-1.fc20


How reproducible:
always

Steps to Reproduce:
$ qmlscene main.qml 
Error:    cz:75:19: illegal escape sequence in string literal
Error:    cz:75:19: syntax error
Error:    Couldn't process include statement for 'cz(qwerty)'
Error:    Abandoning symbols file "(unnamed)"
Error:    Failed to compile xkb_symbols
Error:    Failed to compile keymap
Qt: Failed to compile a keymap

Actual results:
Error:    cz:75:19: illegal escape sequence in string literal
Error:    cz:75:19: syntax error
Error:    Couldn't process include statement for 'cz(qwerty)'
Error:    Abandoning symbols file "(unnamed)"
Error:    Failed to compile xkb_symbols
Error:    Failed to compile keymap
Qt: Failed to compile a keymap


Expected results:
""

Additional info:
I am using Fedora 20 with Mate Desktop. Installed keyboard layouts are "English (US) and Czech (querty)".
Comment 1 Jozef Mlich 2013-10-30 10:50:48 EDT
Seems to be fixed in upstream https://bugs.freedesktop.org/show_bug.cgi?id=68056
Comment 2 Peter Hutterer 2013-12-12 19:49:35 EST
should be fixed with libxkbcommon 0.3.1, can you please test?
Comment 3 Jozef Mlich 2013-12-16 11:22:01 EST
Still not working.

$ qmlscene 
Error:    cz:75:19: illegal escape sequence in string literal
Error:    cz:75:19: syntax error
Error:    Couldn't process include statement for 'cz(qwerty)'
Error:    Abandoning symbols file "(unnamed)"
Error:    Failed to compile xkb_symbols
Error:    Failed to compile keymap
Qt: Failed to compile a keymap
[jmlich@unused-4-145 ~]$ yum info libxkbcommon
Loaded plugins: langpacks, refresh-packagekit
Installed Packages
Name        : libxkbcommon
Arch        : x86_64
Version     : 0.3.1
Release     : 1.fc20
Size        : 394 k
Repo        : installed
From repo   : anaconda
Summary     : X.Org X11 XKB parsing library
URL         : http://www.x.org
License     : MIT
Description : libxkbcommon is the X.Org library for compiling XKB maps into formats usable by
            : the X Server or other display servers.

Available Packages
Name        : libxkbcommon
Arch        : i686
Version     : 0.3.1
Release     : 1.fc20
Size        : 99 k
Repo        : fedora/20/x86_64
Summary     : X.Org X11 XKB parsing library
URL         : http://www.x.org
License     : MIT
Description : libxkbcommon is the X.Org library for compiling XKB maps into formats usable by
            : the X Server or other display servers.
Comment 4 Lukáš Tinkl 2014-06-02 06:52:59 EDT

*** This bug has been marked as a duplicate of bug 1100231 ***

Note You need to log in before you can comment on or make changes to this bug.