Bug 1024906 - gstreamer new plugins like fluidsynth missing
gstreamer new plugins like fluidsynth missing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstreamer1-plugins-bad-free (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 10:56 EDT by Ganapathi Kamath
Modified: 2013-11-14 20:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-14 20:49:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ganapathi Kamath 2013-10-30 10:56:43 EDT
Description of problem:
Upstream seems to mention of new plugins released for gstreamer 1.2 [1][2]
Gstreamer new plugins like fluidsynth missing 
Midi not plying on gstreamer yet, it is a conspicuous issue. 
Maybe there are perhaps other new 1.2 plugins like this also missing. 
I've looked in plugins-bad and plugins-ugly packages also.

Version-Release number of selected component (if applicable):
gstreamer1-plugins*
gstreamer1-1.2*

How reproducible:
since these plugins are new, this is first time introduction issue.

Steps to Reproduce:
1. cd  ls /usr/lib64/gstreamer-1.0/
2. ls
3. # look for plugins
Alternatively goto wikipedia page for Bach
Try to play some midi sample
gstreamer OS needs plugin, audio/x-midi-event decoder missing

Actual results:
corresponding plugin file for some of the new plugins not found
midi plays

Expected results:
midi should work
new plugins from upstream should be present

Additional info:
[1] http://lists.freedesktop.org/archives/gstreamer-devel/2013-September/043124.html
[2] http://cgit.freedesktop.org/gstreamer/gst-plugins-good/tree/NEWS
Comment 1 Ganapathi Kamath 2013-10-30 18:53:14 EDT
$ rpm -qa | egrep -i gstreamer
PackageKit-gstreamer-plugin-0.8.12-1.fc20.x86_64
gstreamer-ffmpeg-0.10.13-9.fc20.x86_64
gstreamer-rtsp-0.10.8-5.fc20.x86_64
gstreamer-plugins-base-0.10.36-6.fc20.i686
gstreamer-plugins-bad-nonfree-0.10.23-2.fc19.x86_64
gstreamer-0.10.36-6.fc20.i686
gstreamer-plugins-bad-free-0.10.23-19.fc20.x86_64
gstreamer1-plugins-ugly-1.2.0-2.fc20.x86_64
gstreamer1-plugins-base-1.2.0-2.fc20.x86_64
gstreamer1-plugins-good-1.2.0-1.fc20.x86_64
gstreamer1-plugins-bad-free-extras-1.2.0-2.fc20.x86_64
gstreamer1-libav-1.2.0-1.fc20.x86_64
gstreamer-plugins-base-0.10.36-6.fc20.x86_64
gstreamer-plugins-good-0.10.31-10.fc20.x86_64
phonon-backend-gstreamer-4.6.3-2.fc20.x86_64
libnice-gstreamer1-0.1.4-2.fc20.x86_64
gstreamer1-plugins-good-extras-1.2.0-1.fc20.x86_64
gstreamer-tools-0.10.36-6.fc20.x86_64
gstreamer-plugins-bad-free-extras-0.10.23-19.fc20.x86_64
gstreamer-python-0.10.22-5.fc20.x86_64
gstreamer1-plugins-bad-free-1.2.0-2.fc20.x86_64
gstreamer-plugins-ugly-0.10.19-13.fc20.x86_64
gstreamer1-1.2.0-1.fc20.x86_64
gstreamer-0.10.36-6.fc20.x86_64
gstreamer-plugins-good-extras-0.10.31-10.fc20.x86_64
Comment 2 Brian Pepple 2013-11-14 20:49:04 EST
Fixed in Rawhide, and will be built in F20 with the next gstreamer release.

commit 852240600c2a2bf05f5dde365260eeb7bf70f5a0
Author: Brian Pepple <bpepple AT fedoraproject.org>
Date:   Thu Nov 14 20:45:35 2013 -0500

    Build fluidsynth plugin. (#1024906)

Note You need to log in before you can comment on or make changes to this bug.