Bug 1024950 - Warnings when importing h5py in python 2.6
Warnings when importing h5py in python 2.6
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: h5py (Show other bugs)
el6
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Steve Traylen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 11:55 EDT by David Jansen
Modified: 2017-06-19 17:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: h5py-1.3.1-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-19 17:16:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jansen 2013-10-30 11:55:17 EDT
Description of problem:

When importing h5py into python, warnings occur.


Version-Release number of selected component (if applicable):

h5py-1.3.1-6.el6.x86_64
python-2.6.6-37.el6_4.x86_64
hdf5-1.8.5.patch1-7.el6.x86_64

How reproducible:

Steps to Reproduce:
1. start python
2. import h5py

Actual results:
Python 2.6.6 (r266:84292, May 27 2013, 05:35:12) 
[GCC 4.4.7 20120313 (Red Hat 4.4.7-3)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import h5py
/usr/lib64/python2.6/site-packages/h5py/__init__.py:24: RuntimeWarning: numpy.dtype size changed, may indicate binary incompatibility
  import h5
/usr/lib64/python2.6/site-packages/h5py/__init__.py:34: RuntimeWarning: numpy.dtype size changed, may indicate binary incompatibility
  import h5, h5a, h5d, h5f, h5fd, h5g, h5l, h5o, h5i, h5p, h5r, h5s, h5t, h5z
>>> 


Expected results:
a quiet import of the module

Additional info:
The warning seems to be only a warning, execution continues and the python module is usable.
Comment 1 Matt 2014-06-20 10:48:12 EDT
Hi Steve,

Any progress on this?  I'm experiencing the issue.

Package versions involved:
h5py-1.3.1-6.el6.x86_64
hdf5-1.8.5.patch1-7.el6.x86_64
numpy-1.4.1.9.el6.x86_64
python-2.6.6-52.el6.x86_64

Temporary work around was to downgrade numpy to numpy-1.3.0-6.2.el6.x86_64.
Comment 2 Fedora Update System 2017-06-01 11:09:50 EDT
h5py-1.3.1-7.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-64d71d6bf8
Comment 3 David Jansen 2017-06-02 06:50:59 EDT
Version 1.3.1-7 from bodhi seems to do the job.
Comment 4 Fedora Update System 2017-06-02 22:50:15 EDT
h5py-1.3.1-7.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-64d71d6bf8
Comment 5 Fedora Update System 2017-06-19 17:16:03 EDT
h5py-1.3.1-7.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.